Page MenuHomePhabricator

Spanish Wikivoyage mainpage initially loads 32MB due to huge images - use thumbnails instead
Closed, InvalidPublic

Description

Spanish Wikivoyage loads _huge_ images. The main page loads 32 MB and takes about 25 seconds here.
While there are no strict limits I'm aware of, this is pretty unfriendly towards anyone on a metered data connection. And slow.

(CC'ing two folks who were recent editors of the main page or its template, as I don't know where to best bring this up. Thanks in advance for taking a look!)

Screenshot from 2023-07-16 21-21-14.png (974×1 px, 965 KB)

Event Timeline

@Aklapper Hi, I made some image changes and the "transclusion" of the "Avisos de Viajes" from eswikinews reducing from 20 news items to 10. Could you check if this has improved or there are still things to fix? I tried to check it myself but it is not clear to me.

I tried to check it myself but it is not clear to me.

Thanks! Please check by using your web browser's developer tools, "network" tab. I'm at a hotel right now with slower internet, and loading https://es.wikivoyage.org/wiki/P%C3%A1gina_principal took 54 seconds for 10.6MB here. So it is a bit better, but I don't think that still waiting for a minute is good, and 10MB is still huge.

Due to the monthly change of the Featured Article. Now the article image weighs about 5 MB and gives you a total of 8 MB with a load time of "2 to 4 seconds" I don't know if it should be changed or so it's fine. As I was saying, I don't have that experience in this part.

Captura de pantalla 2023-08-01 181258.png (881×1 px, 638 KB)

Isn't this something that should be handled on-wiki and not in Phabricator? Anyways the problem is that whatever is loading these images is using the full resolution originals and not thumbnails.

As I was saying, I don't have that experience in this part.

Try to change the "No throttling" setting shown in your browser screenshot - not everybody has fast internet connections. :)

Aklapper renamed this task from Spanish Wikivoyage mainpage initially loads 32MB due to huge images to Spanish Wikivoyage mainpage initially loads 32MB due to huge images - use thumbnails instead.Aug 3 2023, 9:34 AM
Aklapper closed this task as Invalid.

Isn't this something that should be handled on-wiki and not in Phabricator?

Indeed, let's close it here - valid issue but wrong venue.