After uploading files, cannot go back or cancel uploads
Closed, DuplicatePublic


Here is my scenario:

  1. I choose many files - all of them are named P39283982.jpg
  2. I upload them (not seeing thumbnails).
  3. I release all rights.
  4. OMG! I just remembered I cannot upload this one! Where is the back button!

At a very least the user should be able to remove the file or cancel the whole process. Currently you are left alone and don't even know where the files are and how to remove them.

Version: unspecified
Severity: normal

bzimport added a project: UploadWizard.Via ConduitNov 22 2014, 12:04 AM
bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz32247.
Nux created this task.Via LegacyNov 7 2011, 9:29 PM
bzimport added a comment.Via ConduitNov 7 2011, 10:52 PM

neilk wrote:

Good point, we don't have a way to do that now. We should have a way to delete the file on any page, up to the final upload.

Platonides added a comment.Via ConduitDec 23 2011, 12:34 AM

The "available" solution is to close the window but yes, this is suboptimal.

bzimport added a comment.Via ConduitMar 18 2012, 5:35 PM

drecodeam wrote:

added navigation support to navigate through various steps

Bind click handlers to step titles, to navigate to any step from any step. Click handler in turn invokes the moveToStep('<step name>') with the respective step.

attachment 32247.diff ignored as obsolete

bzimport added a comment.Via ConduitMar 18 2012, 5:39 PM

drecodeam wrote:

added .patch file for the previous .diff file

added patch file for the 10256. No changes.

Attached: 32247.patch

bzimport added a comment.Via ConduitMar 18 2012, 7:03 PM

sumanah wrote:

Thanks for the patch, drecodeam. I've added some keywords so people know that your patch awaits review, as you can read about in , and I've given you permissions to add those keywords in the future yourself. :-)

bzimport added a comment.Via ConduitMar 22 2012, 7:40 PM

sumanah wrote:

Also, drecodeam, you can request a Git/Gerrit account

and submit your patch as a merge request to get it reviewed faster:


bzimport added a comment.Via ConduitApr 13 2012, 5:54 PM

drecodeam wrote:

The patch i submitted earlier has some issues with it, as the navigation works but the step divs are not ready right now for navigation. This patch needs more work, and hence is not suitable right now.

MarkAHershberger added a comment.Via ConduitMay 11 2012, 6:11 PM
  • Bug 30687 has been marked as a duplicate of this bug. ***
MarkTraceur added a comment.Via ConduitMay 15 2012, 12:16 AM
  • Bug 36583 has been marked as a duplicate of this bug. ***
MarkTraceur added a comment.Via ConduitMay 29 2012, 4:53 PM

drecodeam, I'm not sure if you're still working on this, but I'm starting to think that it might be better to just add in remove controls on every page until "thanks", serving exactly the same purpose with exactly none of the complications of reverse-navigation. I really can't see a need for moving back to the upload step, since moving *forward* from it would necessarily involve re-uploading the files, which is not a good result. Also, trying to navigate backwards from "thanks" might be complicated, since by that point the files have been fully uploaded and any backwards navigation would involve deleting them from the server and then re-uploading them.

Does anyone have any thoughts on this? Maybe I'm blowing these complications out of proportion?

MarkTraceur added a comment.Via ConduitMay 31 2012, 8:18 PM

I have whipped up a quick patch that adds in "remove" functionality at the details step, which is really the only other place that makes sense (excluding the "upload" step which is obvious). It works really well, it's a very minor change, and I'd appreciate review.

Here it is:

MarkTraceur added a comment.Via ConduitJun 5 2012, 6:15 PM
  • Bug 34191 has been marked as a duplicate of this bug. ***
Aklapper added a comment.Via ConduitAug 14 2012, 4:23 PM

[Offtopic] Mark: Can somebody tell me where the keyword "patch-in-gerrit" was discussed (archives URL?) before it was introduced?

MarkTraceur added a comment.Via ConduitAug 14 2012, 4:28 PM

About ten minutes ago in #mediawiki :)

I had marked a bunch of bugs as patch-need-review, but the description (something like "patch attached, needs review") didn't match what I meant. So Chad added it for me.

gerritbot added a comment.Via ConduitJun 27 2013, 11:08 PM

Change 9549 had a related patch set uploaded by MarkTraceur:
(bug 32247) Add "remove file" in the details step

Aklapper added a comment.Via ConduitMar 11 2014, 2:25 PM

(In reply to Gerrit Notification Bot from comment #15)

Change 9549 had a related patch set uploaded by MarkTraceur:

Patch has been awaiting review for nine months...

Aklapper added a comment.Via ConduitMay 20 2014, 10:43 AM

Patch has been awaiting review for eleven months...

Steinsplitter added a comment.Via ConduitSep 22 2014, 6:55 PM

Open for too long, [ Please rebase your change and upload a new patchset.]

Gilles lowered the priority of this task from "High" to "Normal".Via WebNov 24 2014, 2:18 PM
Gilles added a subscriber: Gilles.
Gilles added a project: Multimedia.Via WebNov 24 2014, 3:14 PM
El_Grafo added a subscriber: El_Grafo.Via WebJun 3 2015, 8:31 AM
Jdforrester-WMF moved this task to Backlog on the Multimedia workboard.Via WebSep 4 2015, 6:40 PM
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptVia HeraldSep 4 2015, 6:40 PM
Matanya closed this task as a duplicate of T26762: Upload wizard: Add bail options.Via WebSep 8 2015, 12:46 AM

Add Comment