Page MenuHomePhabricator

Rollout Elasticsearch extra plugins package and restart cluster to apply
Closed, ResolvedPublic2 Estimated Story Points

Description

Placeholder for building package/rolllng out this version of the plugins package.

Event Timeline

Package builds are failing on build2001.codfw.wmnet , looks to be a checksum error:

sha256sum: WARNING: 5 computed checksums did NOT match
make[1]: *** [debian/rules:53: check_sha256] Error 1
make[1]: Leaving directory '/build/wmf-elasticsearch-searc

debian/blobs/usr/share/elasticsearch/plugins/extra/plugin-descriptor.properties: FAILED
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/plugin[45/8072]or.properties: FAILED
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra/extra-7.10.2-wmf9.jar: No such file or directory
debian/blobs/usr/share/elasticsearch/plugins/extra/extra-7.10.2-wmf9.jar: FAILED open or read
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-turkish/plugin
-descriptor.properties: No such file or directory                                    debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-turkish/plugin-descriptor
.properties: FAILED open or read                                                     sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extra-analysis-ukrainian-7.10.2-wmf8.jar: No such file or directory
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extra-analysis-
ukrainian-7.10.2-wmf8.jar: FAILED open or read
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extr
a-common-7.10.2-wmf8.jar: No such file or directory
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-a
nalysis-slovak-7.10.2-wmf8.jar: No such file or directory
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-analysis-slo
vak-7.10.2-wmf8.jar: FAILED open or read
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-c
ommon-7.10.2-wmf8.jar: No such file or directory
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-common-7.10.
2-wmf8.jar: FAILED open or read
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/plugin-descriptor.
properties: FAILED
sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/extra-analysis-homoglyph-7.10.2-wmf8.jar: No such file or directory
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/extra-analysis-
homoglyph-7.10.2-wmf8.jar: FAILED open or read
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/plugin-descript
or.properties: FAILED
debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/spotbugs-annota
tions-4.7.3.jar: OK

Will check the repo and see if these files are missing.

We did get the package to build.

Gehel set the point value for this task to 2.

Update: the reindex is taking longer than expected. Let's check in again next week.

The reindex mentioned in the above comment was cancelled.

In the meantime, we have rolled out the 7.10.2-9~bullseye package fleet-wide and restarted the cluster.

As such, I'm setting this ticket to "done".