Placeholder for building package/rolllng out this version of the plugins package.
Description
Description
| Status | Subtype | Assigned | Task | ||
|---|---|---|---|---|---|
| Open | None | T312518 Migrate ORES clients to LiftWing | |||
| Resolved | EBernhardson | T328276 Add outlink topic model predictions to CirrusSearch indices | |||
| Resolved | achou | T328899 Add a new outlink topic stream for EventGate main | |||
| Open | None | T291120 MediaWiki Event Carried State Transfer - Problem Statement | |||
| Resolved | Ottomata | T415158 Common event data model for data derived from parsed page revision html (and more!) | |||
| Open | None | T331399 Create new mediawiki links change streams based on fragment/mediawiki/state/change/page | |||
| Resolved | Gehel | T317045 [Epic] Re-architect the Search Update Pipeline | |||
| Resolved | pfischer | T325315 Add support for redirects in CirrusSearch | |||
| Resolved | bking | T344366 Rollout Elasticsearch extra plugins package and restart cluster to apply |
Event Timeline
Comment Actions
Package builds are failing on build2001.codfw.wmnet , looks to be a checksum error:
sha256sum: WARNING: 5 computed checksums did NOT match make[1]: *** [debian/rules:53: check_sha256] Error 1 make[1]: Leaving directory '/build/wmf-elasticsearch-searc debian/blobs/usr/share/elasticsearch/plugins/extra/plugin-descriptor.properties: FAILED debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/plugin[45/8072]or.properties: FAILED sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra/extra-7.10.2-wmf9.jar: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra/extra-7.10.2-wmf9.jar: FAILED open or read sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-turkish/plugin -descriptor.properties: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-turkish/plugin-descriptor .properties: FAILED open or read sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extra-analysis-ukrainian-7.10.2-wmf8.jar: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extra-analysis- ukrainian-7.10.2-wmf8.jar: FAILED open or read sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-ukrainian/extr a-common-7.10.2-wmf8.jar: No such file or directory sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-a nalysis-slovak-7.10.2-wmf8.jar: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-analysis-slo vak-7.10.2-wmf8.jar: FAILED open or read sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-c ommon-7.10.2-wmf8.jar: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/extra-common-7.10. 2-wmf8.jar: FAILED open or read debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-slovak/plugin-descriptor. properties: FAILED sha256sum: debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/extra-analysis-homoglyph-7.10.2-wmf8.jar: No such file or directory debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/extra-analysis- homoglyph-7.10.2-wmf8.jar: FAILED open or read debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/plugin-descript or.properties: FAILED debian/blobs/usr/share/elasticsearch/plugins/extra-analysis-homoglyph/spotbugs-annota tions-4.7.3.jar: OK
Will check the repo and see if these files are missing.
Comment Actions
The reindex mentioned in the above comment was cancelled.
In the meantime, we have rolled out the 7.10.2-9~bullseye package fleet-wide and restarted the cluster.
As such, I'm setting this ticket to "done".