Page MenuHomePhabricator

duplicate link: is not HTML-linked to file page, not red and points to the wrong URL
Closed, ResolvedPublic

Description

Author: saibotrash

Description:
FF 3.6 on openSUSE 11.1

When I try to upload a file which was already uploaded before but was deleted UW displays a warning about this and includes a link to the file. However this link is
<pre>
<a href="#">andere Datei</a>
</pre>
but should be
<pre>
<a href="//commons.wikimedia.org/w/index.php?title=File:Burning_eyes_smileygree2tra4.png&action=edit&redlink=1">andere Datei</a>
</pre>
Otherwise a middle click on it doesn't work. I did it since it seems to be a usual link to a file page on Commons.

Please also color it red if it doesn't exist and use the &action=edit&redlink=1 URL params.


Version: unspecified
Severity: trivial

Details

Reference
bz32606
Related Gerrit Patches:
mediawiki/core : masterUpdate UploadWizard-specific messages
mediawiki/extensions/UploadWizard : masterDisplay duplicates inline rather than in a popup

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:08 AM
bzimport added a project: UploadWizard.
bzimport set Reference to bz32606.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Nov 23 2011, 3:33 PM

OK, so to be clear, the reason this is a problem is because the link opens a modal dialog with, potentially, a _list_ of files for the user to see. I don't think modifying the way this works is the answer. Can we somehow display a list of files to the user in a non-intrusive way that doesn't involve a link which might be misunderstood? Showing the list in the file's div is out of the question, it might be too long. Showing the modal dialog right away is far too intrusive. What would be the better option, here?

OK, so, since this is actually a feature (to support multiple files) and it hasn't gotten any attention despite my question 2.5 months back, I'm going with INVALID for now. Please reopen if it's really that big of a problem....I agree it could be annoying, but it's a minor, minor bug.

Thanks!

saibotrash wrote:

Fine, close all bugs as invalid. ;-) Interesting strategy to reduce the high number of bugs. It is quite offensive to close all the bugs as invalid. Why did I invest time to report them? Because I just want to write a bug report? Or because there is something wrong?!

Make it a button instead of a fake link to file - problem solved, hm?

saibotrash wrote:

Or make it like I proposed but use the onclick event to trigger the modal window. That way a middle/ctrl click should still work.

It was certainly not my intention to offend, and I think you know that. My goal here is, yes, to reduce the number of bugs in the queue--if someone came in and saw this bug, and spent time on it, it could be potentially detrimental.

If there's no other way to close the bug, I can try _exactly one thing_ to solve it, but if that doesn't work, I'm not going to make it a button, because that would be a severely ugly UI change....and when I notice that something is ugly, you have to know it's pretty bad (I am definitely not a designer of any kind).

Your work in reporting these issues is very much appreciated, but your accusation that I'm simply closing bugs willy-nilly is not. I think a lot before closing something.

In this case, I thought that a minor inconvenience (accidentally opening another tab) to a minor subset of people (people who use middle- or ctrl+click) was really not something we had to spend a lot of time on, but I'll give it a few minutes of consideration here.

saibotrash wrote:

I have unwatched all bugs now. Have fun.

OK, I guess we lost Saibo. In any case, after some digging (and sidetracking), I found that the problem is waaaay down in mediawiki/core/resources/mediawiki/mediawiki.jqueryMsg.js:605.

Basically, this shouldn't be href="#", it should be href="javascript:". It's a hack, but it's a helpful hack.

However, I can't test the effects of this, because there are still not proper reports of duplicate or duplicate-archive, which means I can't see these errors.

So, I guess we come back to "I'll revisit this."

Saibo, I'm adding you back. If you're adamant about not being informed about this bug's progress, feel free to re-remove, but I'm glad you're around to help focus people on bugs. I just wish sometimes you could be a little less accusatory about it :)

https://gerrit.wikimedia.org/r/21975

The dialog now no longer ALSO triggers the link target. Ideally, when there is just 1 duplicate, we should just link to the file (with _blank) and not bother with the dialog.

(In reply to comment #8)

https://gerrit.wikimedia.org/r/21975

Status Merged, bug maybe resolved

(In reply to comment #9)

(In reply to comment #8)

https://gerrit.wikimedia.org/r/21975

Status Merged, bug maybe resolved

Saibo: Is this still an issue, or is this FIXED by this patch?

(In reply to comment #8)

Ideally, when there
is just 1 duplicate, we should just link to the file (with _blank) and not
bother with the dialog.

I don't think this is a good solution as we it might seem confusing for the user if sometime its a link to a file and on other times it just opens up a dialog.

I think the bug is still reproducible, I will try to make a fix soon.

No longer working for WMF, so removing assignee to un-lick this cookie.

Only minor comments need to be addressed. This might be a good one for newbies.

(In reply to comment #13)

Only minor comments need to be addressed. This might be a good one for
newbies.

Good, let's add it as GCI task. :)

Qgil added a comment.Dec 26 2013, 5:05 PM

I'm happy to create a GCI task for this report. However, it is unclear to me what is the solution agreed that needs to be implemented.

We avoid sending GCI students to bug reports with discussions and unclear outcome. Do you mind adding a new comment summarizing the work that needs to be done? Thank you!

(In reply to Quim Gil from comment #15)

We avoid sending GCI students to bug reports with discussions and unclear
outcome. Do you mind adding a new comment summarizing the work that needs to
be done? Thank you!

That's fair. In that case it should be just fixed by someone else.

Only a few design issues are left, the comments on the change explain them. I am sure Mark could advise on this on IRC.

This needs input from design and/or mtraceur before adding the "easy" keyword here again, so it's clear for a new contributor what's the path to take and what is the expected solution here. Please elaborate.

Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:40 PM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptSep 4 2015, 6:40 PM
matmarex claimed this task.Sep 10 2015, 6:55 PM
matmarex added a subscriber: matmarex.

OK, so to be clear, the reason this is a problem is because the link opens a modal dialog with, potentially, a _list_ of files for the user to see. I don't think modifying the way this works is the answer. Can we somehow display a list of files to the user in a non-intrusive way that doesn't involve a link which might be misunderstood? Showing the list in the file's div is out of the question, it might be too long. Showing the modal dialog right away is far too intrusive. What would be the better option, here?

We could make the list collapsible. Very often it does contain just one element, I think it's fine to show it in-place. And the dialog is pretty weird here.

Currently, when one is trying to upload files which have (or had) duplicates on the wiki, you get a confusing message which looks like it links to a file but it doesn't.

Clicking any of these hidden links produced a ghastly jQuery UI dialog with a list of file links (even if it would only contain one entry):

With the patch I am working on, the links are gone, and instead you get a "inline" list of file links right next to the error message.

If the list contains more than one entry, it is collapsed by default and can be expanded:

Change 238642 had a related patch set uploaded (by Bartosz Dziewoński):
Display duplicates inline rather than in a popup

https://gerrit.wikimedia.org/r/238642

Change 238643 had a related patch set uploaded (by Bartosz Dziewoński):
Update UploadWizard-specific messages

https://gerrit.wikimedia.org/r/238643

Change 238642 merged by jenkins-bot:
Display duplicates inline rather than in a popup

https://gerrit.wikimedia.org/r/238642

matmarex closed this task as Resolved.Sep 21 2015, 2:53 PM
matmarex removed a project: Patch-For-Review.
matmarex set Security to None.
matmarex removed a subscriber: wikibugs-l-list.

Change 238643 merged by jenkins-bot:
Update UploadWizard-specific messages

https://gerrit.wikimedia.org/r/238643

Qgil removed a subscriber: Qgil.Sep 22 2015, 7:33 AM

Change 50760 abandoned by Bartosz Dziewoński:
Add a redlink to dead duplicate file links

Reason:
Superseded by https://gerrit.wikimedia.org/r/238642

https://gerrit.wikimedia.org/r/50760