Page MenuHomePhabricator

Disable Oversight extension on Wikimedia wikis
Closed, ResolvedPublic

Description

According to the OBSOLETE file [1] in SVN, Oversight/HideRevision was made obsolete in core itself in 1.16, and was supposed to be deleted from the repo at 1.17

Is there any reason we can't just disable it?

Do we need to do any config migration (Aaron?)?

Or is it enough just to remove "require( "$IP/extensions/Oversight/HideRevision.php" );" from CommonSettings.php?

[1] http://svn.wikimedia.org/viewvc/mediawiki/trunk/extensions/Oversight/OBSOLETE?revision=67908&view=markup


Version: unspecified
Severity: normal

Details

Reference
bz32628
Related Gerrit Patches:
mediawiki/tools/release : masterNo longer branch Extension:Oversight
mediawiki/tools/release : masterStop branching Extension:Oversight

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 21 2014, 11:58 PM
bzimport set Reference to bz32628.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Nov 24 2011, 3:54 PM

Does WMF even have revision delete enabled?

I believe its not as simple since we still have all the old over sighted entries that may need to be accessed (unlikely) one day, Although I do believe we have removed the rights globally so no one can actually oversight new materials.

I believe there was talk at one stage of doing a conversion to revdel for the old contents but that was never done because we couldn't decide what levels it should be revdel'ed under (bleh, just do it as the crat levels) and possibly (but I don't remember 100%) a format issue with how they are stored and couldn't be converted into the revdel table format or something.

(In reply to comment #1)

Does WMF even have revision delete enabled?

Yes, It's what is used now.

reachouttothetruth wrote:

The Oversight extension has no way to un-oversight revisions anyway. So disabling shouldn't make a difference. As long as the hidden table is kept, nothing should be lost, right? And then hopefully eventually it can be converted to RevDel.

related: bug 18598

Bug 18598 was closed, hence unless new blockers pop up this is ready for execution.

(In reply to comment #5)

Bug 18598 was closed, hence unless new blockers pop up this is ready for
execution.

Not really, only after bug 60373 is resolved, which may take a while.

(In reply to comment #6)

(In reply to comment #5)

Bug 18598 was closed, hence unless new blockers pop up this is ready for
execution.

Not really, only after bug 60373 is resolved, which may take a while.

Meh, that's a duplicate in practice. And not even properly tagged. Fixing.

tomasz removed a project: Shell.Feb 23 2015, 7:57 PM
tomasz set Security to None.
tomasz added a subscriber: tomasz.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 17 2015, 7:30 AM

Change 231900 had a related patch set uploaded (by Reedy):
Stop branching Extension:Oversight

https://gerrit.wikimedia.org/r/231900

Krenair closed this task as Resolved.Aug 16 2015, 6:15 PM
Krenair claimed this task.
Krenair added a subscriber: Krenair.

Change 231900 abandoned by Alex Monk:
Stop branching Extension:Oversight

Reason:
Duplicate of https://gerrit.wikimedia.org/r/224298/

https://gerrit.wikimedia.org/r/231900

Change 224298 had a related patch set uploaded (by Alex Monk):
No longer branch Extension:Oversight

https://gerrit.wikimedia.org/r/224298

Change 224298 merged by jenkins-bot:
No longer branch Extension:Oversight

https://gerrit.wikimedia.org/r/224298

Awesome! Thanks for seeing this through to the end Krenair :)

Meno25 removed a subscriber: Meno25.Sep 20 2015, 3:25 PM