Page MenuHomePhabricator

Titles in indic languages are partially cut
Closed, ResolvedPublic

Description

Bug 30809 and Bug 29405 are applicable for Many more Indic languages. Indian languages requires line hight a bit bigger than latin languages, because the stacked , below/over base matra signs etc. The Hindi issue was addressed in r99389 and later fixed for Assamese Bengali, Hindi, Malayalam , Odiya in r104160

But this fix should be done for other supported languages too.


Version: unspecified
Severity: normal

Details

Reference
bz32826

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:02 AM
bzimport set Reference to bz32826.
santhosh created this task.Dec 6 2011, 4:23 PM

r105517 addressed this for as, bn, gu, hi, kn, ml, mr, or, pa, sa, ta, te languages

  • Bug 33148 has been marked as a duplicate of this bug. ***
  • Bug 33131 has been marked as a duplicate of this bug. ***

I thought this fix was pushed along 1.19 seeing the release notes http://svn.wikimedia.org/viewvc/mediawiki/branches/REL1_19/phase3/RELEASE-NOTES-1.19?view=markup . Is this deployed and I am still seeing the issue?

(In reply to comment #4)

Is this deployed and I am still seeing the issue?

Can you please provide clearer input. Preferably in the form of specific cases in which you observe that presentation differs from your expectation. If you observe that the issue has been resolved, please close it.

Title Bar getting cut in knwp

(In reply to comment #5)

(In reply to comment #4)

Is this deployed and I am still seeing the issue?

Can you please provide clearer input. Preferably in the form of specific cases
in which you observe that presentation differs from your expectation. If you
observe that the issue has been resolved, please close it.

I have attached the page what I get. The upper part of the title is cut. I remember seeing this issue addressed in http://kn.wikipedia.beta.wmflabs.org/ but cant confirm now since its down. This was on Ubuntu / Chrome. I dont see this on Win XP + Firefox

Am seeing an even more critical issue with WebFonts(possibly due to Lohit 2.5.1 ?) on WinXP + Chrome. Logging that in few minutes, or may be both could be related.

Attached:

Marking browser as chrome, since I cant reproduce it on IE / FF

Srikanth, can you confirm this by using Kannada interface? the css rules for line height are language specific

(In reply to comment #8)

Srikanth, can you confirm this by using Kannada interface? the css rules for
line height are language specific

So yes, works for me on kn interface. But should this check be on the language of wiki / language of the page instead of interface language of the user?

Removing chrome since its was observed on Firefox / Chromium after using en interface.

(In reply to comment #9)

(In reply to comment #8)

Srikanth, can you confirm this by using Kannada interface? the css rules for
line height are language specific

So yes, works for me on kn interface. But should this check be on the language
of wiki / language of the page instead of interface language of the user?

Can you share the URL of that page? If there is any parent node with lang=kn the rules will apply. But looking at similar pages as in screenshot, I see it is only 'en'. If there is a way to tell that first heading is in language kn, the language specific rules will make bigger line height.

As srikanth confirmed in the IRC, the case comes only when page language, or parent nodes or the node itself has no information about language or it is en(user interface language). So it is an issue of not having sufficient and correct language attributes.
If any node is marked with kn, the fix did for this bug get applied.
So closing this bug.