All the pages of Bengali wiki loads twice for the webfonts
Closed, InvalidPublic


I have tested this extension for the Bengali wikipedia form some of the browsers (Firefox 7 & 8 from windows 7 and XP, Chrome 15.0 windows 7 and XP, Firefox 7 form Uubntu 11.10) in different machines and in every case i had to face the same problem, that the page loads twice and takes an extra time for each of the pages.

At the very first time the page loads with the system default font and then the whole page became empty and after that the browser shows the content with the selected web font.

and it takes some extra time to show the full page.

nasir khan saikat
Wikimedia Bangladesh

Version: unspecified
Severity: minor
Platform: PC

bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz33174.
Nasirkhan created this task.Via LegacyDec 15 2011, 8:13 PM
santhosh added a comment.Via ConduitDec 19 2011, 11:03 AM

This is called FOUT, Flash Of Unformattes/Unstyled Text. And inherent with webfont technology, eventhough browsers are trying to reduce the impact on user experience. When you visit a page, the font is also getting downloaded just after browser understand that a font need to be downloaded. Firefox shows the page in default font, and when font is downloaded, it shows the text in that font. This causes a flickering in the screen, but it is not loading twice, its rendering twice. Some other browsers just display a blank space for the text and start rendering it only when font is downloaded, so there is no double rendering, but blank page for a few (milli)seconds.

But this behavior happens only when you download the font for fist time, ie when you visit a wiki with webfont for first time. Second time onwards browsers should use the font from cache.

Read more about it on

Yes, time taken for page will be a little extra than the time taken for page without webfont. But all these are much visible only at the first use of webfont. when you navigate to other wikipages, it will be normal since font is not getting downloaded and used from cache.

Logicwiki added a comment.Via ConduitDec 19 2011, 11:22 AM

And I guess if bug 33027 is fixed / performance is improved (In terms of bandwidth consumed, memory used on client side {though getting these data might be difficult and then getting delta improved might be even more difficult}), FOUT effect will be much shorter even for the first time the font gets download.

siebrand added a comment.Via ConduitDec 19 2011, 1:25 PM

Please submit proof that pages are loaded twice, for example using a firebug screenshot. Bug 33027 is not directly related.

Nasirkhan added a comment.Via ConduitDec 20 2011, 9:55 AM

Created attachment 9749
screen capture at the time of page load

i have attached a video where you can see the page load. hope this might be helpful .
it is captured form Windows 7 Google Chrome web browser

Attached: Bug_33174_nasir_khan_saikat_20dec2022.mp4

siebrand added a comment.Via ConduitDec 20 2011, 10:00 AM

Thanks for the video in comment 4.

As explained in comment 1, this is FOUT, and not the page being loaded twice (it's being rendered twice, if anything, once without styling, once with styling). Some additional confusion is added into the mix by the fundraising banner pushing the page down. Your observation is expected behaviour.

I think this issue should be closed INVALID.

santhosh added a comment.Via ConduitDec 20 2011, 10:11 AM

I am closing thiis bug since what we observed is expected behavior. If you navigate to some pages in the wiki, you wont see this because font is cached.

Add Comment