Page MenuHomePhabricator

Error when assigning global group permissions to an account with spaces
Closed, ResolvedPublic

Description

Author: peter_symonds

Description:
There appears to be an error when assigning global user rights to a global account with spaces. Earlier I tested it by assigning my test account global IP block exempt:

(show/hide) 16:08, 1 January 2012 PeterSymonds (talk | contribs | block) changed global group membership for User:Peter Symonds from global-ipblock-exempt to (none) ‎ (done)
(show/hide) 16:07, 1 January 2012 PeterSymonds (talk | contribs | block) changed global group membership for User:Peter Symonds from (none) to global-ipblock-exempt ‎ (testing bug in global rights interface; will revert in a few seconds)

The following message was thrown back:

"The global user PeterSymonds_(test) is not active on the wiki you specified ( aawiki ). You may be attempting to assign rights to the wrong user!"

Despite this message, as the log shows, the right was assigned successfully. Furthermore, I didn't attempt to assign the right on aawiki; it was assigned on Meta-Wiki.


Version: unspecified
Severity: normal

Details

Reference
bz33458

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:04 AM
bzimport set Reference to bz33458.
bzimport added a subscriber: Unknown Object (MLST).

peter_symonds wrote:

Sorry, I tested it twice, with two accounts. The error message appeared both times, for "PeterSymonds (test)" and "Peter Symonds".

Looks similar to bug 24826, caused by wrong username normalization (and at least partially fixed).

Cannot reproduce. Probably fixed by https://gerrit.wikimedia.org/r/#/c/153743/ if not something earlier.

Krenair closed this task as Resolved.Apr 4 2015, 1:26 AM
Krenair claimed this task.
Krenair reassigned this task from Krenair to hoo.
Krenair set Security to None.