Page MenuHomePhabricator

Mediaviewer download options not showing the file size data
Closed, ResolvedPublicBUG REPORT

Assigned To
Authored By
RHo
Jan 24 2024, 11:51 AM
Referenced Files
F41714836: image.png
Jan 24 2024, 10:27 PM
F41714424: image.png
Jan 24 2024, 6:22 PM
F41713541: image.png
Jan 24 2024, 11:51 AM
Subscribers

Description

Steps to replicate the issue (include links if applicable):

  • Select the download icon button on the bottom right of mediaviewer
  • Select the dropdown arrow to choose download file size

What happens?:
Each file size option appears to be showing the string name instead of the value. See for example below, it shows <multimediaviewer-original-embed dimensions>

image.png (656×1 px, 272 KB)

What should have happened instead?:
The actual value (Download medium size - 1129 x 720 px) should be displayed instead.

Other information (browser name/version, screenshots, etc.):
Screenshot above from 24-Jan-2024 image of the day.

Event Timeline

Could be a transient issue with the localization cache, that happens sometimes during deployments. If that's the case, the next time someone deploys a patch will fix it (or did fix it - seems to work fine for me now).

Interesting... fwiw still happening for me consistently in different browsers on different images

image.png (1×3 px, 2 MB)

What do you get when running mw.config.get('wgHostname') in the console?

Also can you check the X-Cache header on the ResourceLoader asset? (In Chrome: run mw.loader.store.clear(), reload the page, open the network panel of the developer console, press Ctrl-Shift-F, type multimediaviewer-original-embed-dimensions in the search bar that comes up, select the result which starts with load.php, double-click to open in Sources panel, right-click the tab of that file and select "Reveal in Network panel", click on the highlighted line in the list of requests.)

What do you get when running mw.config.get('wgHostname') in the console?

I get 'mw1477'

Also can you check the X-Cache header on the ResourceLoader asset? (In Chrome: run mw.loader.store.clear(), reload the page, open the network panel of the developer console, press Ctrl-Shift-F, type multimediaviewer-original-embed-dimensions in the search bar that comes up, select the result which starts with load.php, double-click to open in Sources panel, right-click the tab of that file and select "Reveal in Network panel", click on the highlighted line in the list of requests.)

Ahhhh I think you found my limit in dev debugging skillz as I am not quite sure what I'm looking at now!

image.png (676×3 px, 321 KB)

However, it seems like the problem is now fixed, so maybe just took a bit for the patch to come through... thanks for checking up and I'll close the ticket if it is a transient thing.

RHo claimed this task.