Page MenuHomePhabricator

[QB] Chore: Update dependencies in Query Builder
Closed, ResolvedPublic

Description

Update dependencies in Query Builder.

In the README you can find guidelines on how to update the dependencies.

If there are any issues, create a subtask.

If there are open Addbot patches then either comment recheck and +2 them, or abandon them, or create a task if they need more work. (The dependabot pull requests that trigger the Addbot patches can usually be ignored. dependabot will close them eventually.)

Event Timeline

Discoveries, stylelint can't be upgraded to v16 until there is a new version of stylelint-use-logical that supports it. Our current installed version of stylelint-use-logical: 2.1.0, supports:

"peerDependencies": {

  "stylelint": ">= 11 < 16"
},

See: https://github.com/csstools/stylelint-use-logical/blob/main/package.json#L45

Change 994741 had a related patch set uploaded (by Guergana Tzatchkova; author: Guergana Tzatchkova):

[wikidata/query-builder@master] Chore: upgrade eslint packages that can be upgraded

https://gerrit.wikimedia.org/r/994741

Change 994741 merged by jenkins-bot:

[wikidata/query-builder@master] Chore: upgrade eslint packages that can be upgraded

https://gerrit.wikimedia.org/r/994741

Change 994744 had a related patch set uploaded (by Guergana Tzatchkova; author: Guergana Tzatchkova):

[wikidata/query-builder@master] Chore: Upgrade @wikimedia/language-data

https://gerrit.wikimedia.org/r/994744

Change 994744 merged by jenkins-bot:

[wikidata/query-builder@master] Chore: Upgrade @wikimedia/language-data

https://gerrit.wikimedia.org/r/994744

T356410 was created to investigate why netlify-cli can't be updated.