Page MenuHomePhabricator

#REDIRECT with transcluded string does not redirect
Open, LowPublic

Description

Author: silsor

Description:
An example of something I wanted to do:

#REDIRECT [[Wikipedia:Today's featured article/{{CURRENTMONTHNAME}} {{CURRENTDAY}},
{{CURRENTYEAR}}]]

This displays as if &redirect=no were included in the URL. No redirection happens.

Bug #927 sounds similar to this by the title but by the description it seems to be a
different bug.


Version: 1.4.x
Severity: minor

Details

Reference
bz1575

Event Timeline

bzimport raised the priority of this task from to Lowest.
bzimport set Reference to bz1575.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Feb 21 2005, 7:14 PM
brion added a comment.Feb 21 2005, 8:12 PM

A redirect must specify an actual title.

rowan.collins wrote:

*** Bug 1685 has been marked as a duplicate of this bug. ***

gangleri wrote:

http://jadesukka.homelinux.org:8180/betawiki/Today%27s_featured_article

provides a workaround for the the original request using
{{Today's featured article/{{CURRENTMONTHNAME}} {{CURRENTDAY}}, {{CURRENTYEAR}}}}

Note: It is *safer* to use inclusions from the *template* namespace. The
original request asked for an inclusion of a page from the *project* namespace
where several restrictions would apply.

Regards Reinhardt [[user:gangleri]]

gangleri wrote:

in response to comment 0

A redirect must specify an *actual title*.

The original templates include variables. The examples below do *not*.

http://test.leuksman.com/index.php?title=Template:R1link&action=edit
[[Main Page]]
http://test.leuksman.com/index.php?title=Template:R1&action=edit
Main Page

http://test.leuksman.com/index.php?title=R1link&action=edit
#REDIRECT {{R1link}}
http://test.leuksman.com/index.php?title=R1&action=edit
#REDIRECT [[{{R1}}]]
None of the last would generate a redirect.

These redirects are quite theoretical but to some extend they are unchanged
*actual title* as a distinction from the templates in comment 0 where variables
are used.

Anyhow changes in both cases would be triggered at another / other objects then
the redirect page itself and "adjusting link tables" would have a similar level
of complexity which could grow if nested templates would be used.

Despite the fact that the requirement is quit intuitive it would be probably
best to leave this request as "WONTFIX".

Best regards Reinhardt [[user:gangleri]]

gangleri wrote:

*** Bug 4763 has been marked as a duplicate of this bug. ***

gangleri wrote:

*** Bug 4882 has been marked as a duplicate of this bug. ***

brion added a comment.Jun 4 2006, 6:51 PM
  • Bug 6196 has been marked as a duplicate of this bug. ***
brion added a comment.Oct 27 2006, 2:11 PM
  • Bug 7727 has been marked as a duplicate of this bug. ***

forums wrote:

Is there any news about that bug ? (sorry for having created one other ...)

ayg wrote:

The official word since February 21, 2005 is that it's not going to be changed,
and indicated by CLOSED WONTFIX. Argue with Brion about it on IRC if you want,
but he's the lead developer and what he's said stays out of the code stays out
of the code until he says otherwise.

forums wrote:

Do we know why it's marked as CLOSED WONTFIX ?
Looked from Brion on IRC, not there ... :(

rainman wrote:

(In reply to comment #11)

Please look at Brion's comments on earlier duplicate bugs (e.g. Bug 4763 and Bug
4882)

IAlex added a comment.Aug 24 2009, 5:05 PM
  • Bug 17183 has been marked as a duplicate of this bug. ***
  • Bug 40289 has been marked as a duplicate of this bug. ***
  • Bug 61791 has been marked as a duplicate of this bug. ***
  • Bug 61791 has been marked as a duplicate of this bug. ***
MGChecker reopened this task as Open.EditedMay 7 2015, 4:06 PM
MGChecker added a subscriber: MGChecker.

I think reopening this task were really good, because some time has left since this more than 10 years old request was declined. What was the reason that it was rejected and is it possible now?

MGChecker raised the priority of this task from Lowest to Normal.May 7 2015, 4:08 PM
MGChecker set Security to None.
Xqt added a subscriber: Xqt.Jun 1 2015, 5:47 AM
MGChecker raised the priority of this task from Normal to Needs Triage.Jun 23 2015, 8:50 PM
Aklapper triaged this task as Low priority.Jun 24 2015, 11:05 AM
Danny_B added a subscriber: brion.Jan 11 2016, 4:55 PM
Krinkle moved this task from Untriaged to General on the MediaWiki-Redirects board.