Page MenuHomePhabricator

WikiEditor: ext.wikiEditor.toolbar.hideSig.js is loaded even when the enhanced editing toolbar is disabled
Closed, InvalidPublic

Description

Seen on de.wikipedia.beta.wmflabs.org
To reproduce this disable the WikiEditor toolbar in your preferences. The module ext.wikiEditor.toolbar.hideSig is still loaded, which doesn't hurt but is superfluous.


Version: unspecified
Severity: minor

Details

Reference
bz33923

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:04 AM
bzimport added a project: WikiEditor.
bzimport set Reference to bz33923.
bzimport added a subscriber: Unknown Object (MLST).
Schnark created this task.Jan 24 2012, 10:59 AM

I believe this is issue related to squid

Reedy added a comment.Jan 31 2012, 7:41 PM

It happens on enwiki on 1.18wmf1;

It's not a labs specific bug

Reassigning back to default assignee

Should be fixed up at some point

Reedy added a comment.Jan 31 2012, 8:23 PM

// Hide signature button from main namespace
'hidesig' => array( 'global' => true, 'user' => false ),

I'm guessing it's cause the function is globally on... So it's always loaded

Might actually be a wontfix, as might not be doable without a lot of work

hashar added a comment.May 3 2012, 2:23 PM

Per comment 2 stating that this bug is not labs specific, I am removing dependency on "Bug 33578 - several bugs on deployment test site for 1.19"

Might actually be a wontfix, as might not be doable without a lot of work

In the interim, ext.wikiEditor.toolbar.hideSig.js has stopped "working" altogether since this report was first filed and any related subsequent changes made afterwards per T42972 (among others). Fixing this has become a moot point; removing completely should be the focus moving forward.

In a nutshell, one would need to undo/revert the current day equivalents of the merge that first introduced the module attached within T30149
( which is better outlined at https://www.mediawiki.org/wiki/Special:Code/MediaWiki/86703 fwiw... ).

GOIII renamed this task from ext.wikiEditor.toolbar.hideSig is loaded even when the toolbar is disabled to WikiEditor: ext.wikiEditor.toolbar.hideSig.js is loaded even when the enhanced editing toolbar is disabled.Nov 30 2014, 12:07 AM
GOIII raised the priority of this task from Low to Needs Triage.
GOIII set Security to None.
hashar removed a subscriber: hashar.Dec 1 2014, 12:40 PM
GOIII added a subscriber: Paladox.Dec 4 2014, 1:39 AM

Can you please formulate a simple regression of the implementation of hideSig (outlined in T35923) as an alternative to r102076 / r87649?
Those fixes have been in limbo for months if not a year or more and it doesn't seem like any consensus will be reached this time around either.
A simple regression to the state prior to the implementation of the hideSig script shouldn't impair anything for the alternative efforts either.

TheDJ triaged this task as Low priority.Mar 15 2015, 6:12 PM
Schnark closed this task as Invalid.Aug 6 2015, 8:31 AM
Schnark claimed this task.

Module no longer exists in new implementation.

GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:45 AM