Page MenuHomePhabricator

Drop PHP 7.4 and 8.0 support from MediaWiki 1.42; require PHP 8.1+
Closed, ResolvedPublic

Description

[Proposal]

Event Timeline

Change 1010310 had a related patch set uploaded (by Jforrester; author: Jforrester):

[integration/config@master] Configure REL1_42 branch support, with PHP 8.1+ support only

https://gerrit.wikimedia.org/r/1010310

Change 1010310 merged by jenkins-bot:

[integration/config@master] Configure REL1_42 branch support, with PHP 8.1+ support only

https://gerrit.wikimedia.org/r/1010310

Mentioned in SAL (#wikimedia-releng) [2024-03-18T15:02:19Z] <James_F> Configure REL1_42 branch support, with PHP 8.1+ support only for T359838 and T359868

Provisionally agreed in today's MW 1.42 release check-in.

Change #1017949 had a related patch set uploaded (by Jforrester; author: Jforrester):

[mediawiki/core@master] INSTALL: Update nominal required minimum PHP supported level to 8.1.0

https://gerrit.wikimedia.org/r/1017949

Change #1017949 merged by jenkins-bot:

[mediawiki/core@master] INSTALL: Update nominal required minimum PHP supported level to 8.1.0

https://gerrit.wikimedia.org/r/1017949

Change #1017958 had a related patch set uploaded (by Jforrester; author: Jforrester):

[mediawiki/core@REL1_42] Bump PHPVersionCheck & composer expected PHP versions to 8.1.0

https://gerrit.wikimedia.org/r/1017958

Change #1017958 merged by jenkins-bot:

[mediawiki/core@REL1_42] Bump PHPVersionCheck & composer expected PHP versions to 8.1.0

https://gerrit.wikimedia.org/r/1017958

Change #1017958 merged by jenkins-bot:

[mediawiki/core@REL1_42] Bump PHPVersionCheck & composer expected PHP versions to 8.1.0

https://gerrit.wikimedia.org/r/1017958

That broke the Doxygen documentation generation T362385