Page MenuHomePhabricator

[cicd,infra] Add python 3.11/bookworm support
Closed, ResolvedPublic

Description

Now that we will be moving out of the old grid bastions, the newer ones have python 3.11 on debian bookworm, so we should start testing for that instead.

Event Timeline

dcaro triaged this task as Medium priority.Mar 19 2024, 9:38 AM

Mentioned in SAL (#wikimedia-cloud) [2024-03-19T09:38:04Z] <dcaro> pushed docker-registry.tools.wmflabs.org/cloud-cicd-py311bookworm-tox:latest and docker-registry.tools.wmflabs.org/cloud-cicd-debian-builder-bookworm:2024-03-24.1 (T360405)