Gadgets stopped working on enwiki beta and commons beta
Closed, ResolvedPublic

Description

As titled. Gadgets refuse to run, but there are *no* errors; they just don't run. Gadgets do seem to be loaded though, as CSS associated with gadgets is active.


Version: unspecified
Severity: critical
URL: http://en.wikipedia.beta.wmflabs.org/wiki/Main_Page

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz34195.
Edokter created this task.Via LegacyFeb 3 2012, 10:44 PM
Reedy added a comment.Via ConduitFeb 3 2012, 10:58 PM

Seemingly not completely broken...

"Adds two new dropdown boxes below the edit summary box, with some useful default summaries." works, but Hotcat doesn't

Edokter added a comment.Via ConduitFeb 4 2012, 2:33 PM

OK, some work, some don't. Those that don't work simply don't have their JS components not loaded. Popups is broken on Commons, but EditTop works.

Edokter added a comment.Via ConduitFeb 5 2012, 5:56 PM

This is critical and must be investigated before 1.19 is branched *this week*. Assigning to Krinkle, as this might be related to some modifications done to ResourceLoader in the past week.

Reedy added a comment.Via ConduitFeb 6 2012, 3:24 PM

(In reply to comment #3)

This is critical and must be investigated before 1.19 is branched *this week*.
Assigning to Krinkle, as this might be related to some modifications done to
ResourceLoader in the past week.

It's not a blocker to branching, but certainly is to deployment

As for when it's actually going to be done... It'd be nice if we knew that

MarkAHershberger added a comment.Via ConduitFeb 7 2012, 12:51 AM

This looks like bug 34147 to me

Edokter added a comment.Via ConduitFeb 7 2012, 1:13 AM

But I'm not getting eny errors (on enwiki beta). I do see 'addOnloadHook is not defined on Commons beta. Also of interest, with ?debug=true, enwiki gadgets do seem to work, but the navigation bar states are reversed (they show collapsed, but the arrows point down).

MarkAHershberger added a comment.Via ConduitFeb 7 2012, 7:52 PM

Hrm... on further investigation, I see what you're talking about. Interestingly, enabling the "Use a black background with green text on the Monobook skin" without the Vector skin -- which I've done repeatedly in the past -- does change *most* of the background to black with green text but leaves some oddities. The "Main page" link in the side bar isn't click-able, for example

MarkAHershberger added a comment.Via ConduitFeb 8 2012, 9:28 PM

AFTv5 was enable for enwiki.beta and was causing this.

Add Comment