Page MenuHomePhabricator

Available settings for result parameter "order" on Special:Ask doubled (1.8.0)
Closed, DeclinedPublic

Description

When using result formats on Special:Ask which allow the usage of the parameter order you get to choose between "descending", "desc", "asc", "ascending", "rand" and "random". Both long text and abbreviation are shown. In order to avoid confusion and easier understanding of the choices I suggest to remove the abbreviation from display. (only on Special:Ask, not on SMW of cause ;)


Version: unspecified
Severity: normal

Details

Reference
bz34461

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:19 AM
bzimport set Reference to bz34461.
bzimport added a subscriber: Unknown Object (MLST).
Kghbln created this task.Feb 17 2012, 12:58 AM

Not trivial to implement. There is no value aliasing support. One could ofc put in some hardcoded stuff in the form input creation code, but that'd be nasty IMO.

  • Bug 34850 has been marked as a duplicate of this bug. ***
Aklapper closed this task as Declined.Mar 3 2015, 5:50 PM
Aklapper added a subscriber: Aklapper.

The Semantic MediaWiki developers requested in https://phabricator.wikimedia.org/T64114 to move their task tracking to https://github.com/SemanticMediaWiki/SemanticMediaWiki/issues and to close remaining tasks in Wikimedia Phabricator. If you still face the problem reported in this task in a supported version of SMW, please feel free to transfer your report to https://github.com/SemanticMediaWiki/SemanticMediaWiki/issues . We are sorry for the inconvenience.