There was some discussion about this on wikitech on January,
but since the nomenclature didn't change so far, I'm opening this request to make changes such as the following in the bugzilla interface:
- Vote --> Watch|BookMark
- Show Votes --> Show bugs I watch|Show my Bookmarks
- 1 vote used out of 1000 allowed. --> Watching 1 bug of 1000 allowed.|1 bookmark used out of 1000 allowed.