Page MenuHomePhabricator

Add shortcut for linking to templates in edit summaries (e.g. {{foo}} -> [[Template:Foo]])
Closed, DeclinedPublic

Description

See following diff/history:
"(missed the realname parameter of the {{infobox wikipedian}})"
the {{infobox wikipedian}} should be automatically linked.

https://secure.wikimedia.org/wikipedia/en/w/index.php?title=Template:Infobox_user&curid=3615435&diff=481529078&oldid=481157351

Details

Reference
bz35174

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:15 AM
bzimport set Reference to bz35174.
bzimport added a subscriber: Unknown Object (MLST).
Mabdul created this task.Mar 12 2012, 5:16 PM
  • This bug has been confirmed by popular vote. ***

Regular wikilinks continue to work, but templates weren't linked in 1.18 -- this is not a regression, this is a feature request.

wikipedia uses 1.19 so the "bug"/feature request is also for the actual version; nevertheless this is in my eyes more a bug, if wikilinks work, why shouldn't templates working/properly linked?

MGChecker updated the task description. (Show Details)
Krinkle renamed this task from automatic linking of templates in edit summaries to Add shortcut for linking to templates in edit summaries (e.g. {{foo}} -> {{[[Template:Foo|foo]]}}).Feb 9 2019, 7:05 PM
Krinkle removed a subscriber: wikibugs-l-list.
Krinkle renamed this task from Add shortcut for linking to templates in edit summaries (e.g. {{foo}} -> {{[[Template:Foo|foo]]}}) to Add shortcut for linking to templates in edit summaries (e.g. {{foo}} -> [[Template:Foo]]).Apr 9 2019, 1:48 AM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptApr 9 2019, 1:48 AM
Krinkle added a subscriber: Krinkle.

This task represents a proposal to change the way text is parsed inside edit summaries. Changes to the way content is parsed are quite challenging due to the potential to break existing text from users. This is because the output is not permanently transformed. Each time you view a history page, or save an edit, it is re-expanded based on the latest version.

That is not to say it can never be changed, but there is a very sizable cost to doing so with regards to understanding its impact on existing content, and taking measures to mitigate it (e.g. versioning, or db migration etc.).

Given the relatively small benefit of being able to use {{foo}}, and the regular link syntax already working as [[template:foo]], I'd suggest declining this feature request.

Tagging CPT for further consideration / decision.

daniel added a subscriber: daniel.Apr 17 2019, 7:00 PM

@Krinkle or {{foo}} could expand to [[template:foo]] upon save. We do that with ~~~~ even in summaries, don't we?

@daniel No, there are no substitutions on the edit summary apart from link syntax. All other text is preserved as is. I imagine it's not unlikely to have edit summaries like "Fix bug with ~~~" or "Forgot to add ~~~~". example.

daniel closed this task as Declined.Apr 17 2019, 7:51 PM

Declined, per Timo. It has been around for seven years, and there doesn't seem to be much demand.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptApr 17 2019, 7:51 PM