Site/Location: eqiad
Number of systems: 1
Service: wdqs-categories
Networking Requirements: internal
Processor Requirements: 8 vCPU
Memory: 24 GB vRAM
Disks: 60 GB
Comment:
Testing Ganeti as a potential home for wdqs-categories (a separate blazegraph instance that enables deep category search on wikis). See T374016 for more details.
Description
Details
| Subject | Author | Repo | Branch | Lines +/- | |
|---|---|---|---|---|---|
| wdqs-categories: use correct insetup role | Bking | operations/puppet | production | +1 -1 | |
| wdqs-categories: introduce VM for testing | Bking | operations/puppet | production | +15 -3 |
| Status | Subtype | Assigned | Task | ||
|---|---|---|---|---|---|
| Open | None | T335067 Epic: Wikidata Query Service stabilization | |||
| Resolved | BTracy-WMF | T337013 [Epic] Splitting the graph in WDQS | |||
| Resolved | bking | T374967 wdqs-categories migration: decide where to migrate | |||
| Open | None | T375520 EPIC: WDQS categories migration | |||
| Resolved | bking | T375687 Test categories performance under Ganeti | |||
| Resolved | bking | T376079 eqiad: request 1 VM for wdqs-categories |
Event Timeline
Change #1076841 had a related patch set uploaded (by Bking; author: Bking):
[operations/puppet@production] wdqs-categories: introduce VM for testing
Our upper boundary for VMs is 16G (the current virt servers have 64G, the next capex will bump these to 128), if you need anything 24G you need to temporarily repurpose some baremetal servers.
ACK, I will go ahead and provision a VM at 16 GB . As you can see from this graph , Categories typically takes ~9 GB but increases to ~20 during its daily reload. We're going to test a reload at 16 GB vRAM and see if it works.
Change #1076841 merged by Bking:
[operations/puppet@production] wdqs-categories: introduce VM for testing
Cookbook cookbooks.sre.hosts.reimage was started by bking@cumin2002 for host wdqs-categories1001.eqiad.wmnet with OS bullseye
Cookbook cookbooks.sre.hosts.reimage started by bking@cumin2002 for host wdqs-categories1001.eqiad.wmnet with OS bullseye executed with errors:
- wdqs-categories1001 (FAIL)
- Removed from Puppet and PuppetDB if present and deleted any certificates
- Removed from Debmonitor if present
- Forced PXE for next reboot
- Host rebooted via gnt-instance
- Host up (Debian installer)
- Add puppet_version metadata to Debian installer
- Set boot media to disk
- Host up (new fresh bullseye OS)
- Generated Puppet certificate
- Signed new Puppet certificate
- Run Puppet in NOOP mode to populate exported resources in PuppetDB
- The reimage failed, see the cookbook logs for the details,You can also try typing "sudo install-console wdqs-categories1001.eqiad.wmnet" to get a root shellbut depending on the failure this may not work.
Change #1077427 had a related patch set uploaded (by Bking; author: Bking):
[operations/puppet@production] wdqs-categories: use correct insetup role
Change #1077427 merged by Bking:
[operations/puppet@production] wdqs-categories: use correct insetup role
The VM wdqs-categories1001 has been provisioned successfully, so I'm closing out this task.