Complete unification of all accounts to SUL
Closed, ResolvedPublic

Tokens
"Mountain of Wealth" token, awarded by Mattflaschen-WMF."Yellow Medal" token, awarded by Rdicerb."Love" token, awarded by Neil_P._Quinn_WMF."Love" token, awarded by greg."Orange Medal" token, awarded by Steinsplitter."Mountain of Wealth" token, awarded by Harej."Yellow Medal" token, awarded by bd808."Love" token, awarded by Ricordisamoa.
Assigned To
Authored By
MarkAHershberger, Apr 4 2012

Description

From the (un)-archived discussion at meta (http://meta.wikimedia.org/w/index.php?title=Wikimedia_Forum&diff=next&oldid=3619272), [[User:JohnnyMrNinja]] writes (in part):

I am proposing that account unification be completed for all eligible accounts
without requiring the user to take any additional steps. This would make UL the
rule rather than the exception that it currently is, and bring us closer to the
goals of universal watchlists, recent changes, interwiki page moves, etc. This
would be especially helpful on Commons, which has so many images that were
originally uploaded at another WMF wiki, enabling better attribution without
interwiki links. I propose that it be carried out as a one-time process rather
than a continuous automatic software process, allowing users to still adjust
ULs as they see fit.

[...]what I mean by "eligible accounts" was all accounts without existing
conflicts, as these can be taken care of by an automated process. Accounts that
have conflicts would be unaffected by this specific proposal. Conflicts could
not be solved by any automated process, as each case would be different.

Looks like it has enormous support on meta. I'm not sure about the ins and outs here, so I'm going to add people who I think know more as well as post this bug to wikitech-l.


Version: unspecified
URL: https://meta.wikimedia.org/wiki/Single_User_Login_finalisation_announcement
See Also:
T41817: Migrate to SUL all non-clashing accounts
T38939: User name blacklist should be managed globally to avoid SUL fragmentation

Details

Blocks
T74469: OAuth: Authorisation should not fail because you don't have an account on central wiki
T1382: Add login and create account links to www project portals
T24673: if last local account is moved sul should be deleted by itself
T51315: [Story] record wikibase recent change entries attributed as non-anon
T68699: Increase "remember me" login cookie expiry from 30 days to 1 year on Wikimedia wikis
T4007: [DO NOT USE] Tracking bug [superseded by the #Tracking tag]
T51740: watchlist filter to not show own edits doesn't work for Wikidata edits
T18690: Re-work messaging about global account status [[Special:Preferences]] once all accounts are SUL accounts
Blocked By
T106069: Edits on enwiki detached from auto-renamed user account need reattaching
T70069: Set $wgCentralAuthPreventUnattached = true; on all wikis
T69995: Allow login in with pre-rename username and password
T73241: Run sendConfirmAndMigrateEmail.php for all unconfirmed emails on all wikis
T69901: Add config setting to prevent creation of new unattached accounts
T71291: Run migrateAccount.php without --safe or --auto
T72850: Not possible to filter Special:Log/gblrename by old CentralAuth account name
T70927: Prevent new account creations from taking names that have been requested in a pending rename request
T70924: Create special page to manage global rename request queue
T70886: Request global account rename from home wiki before forced SUL name change
T69350: Audit centralauth database for inconsistencies
T72392: Allow to automatically unify on login absent clashes
T74123: Add a maintenance script to send mass messages
T63876: Attach all broken autocreated local accounts to their global account
T73924: Add users_to_rename table to centralauth database
T56761: EmailableUser calls non-existing class ConfirmAndMigrateUser
T56760: sendConfirmAndMigrateEmail.php: add an option to include emailconfirmed accounts
T41817: Migrate to SUL all non-clashing accounts
T49918: Rename of global (attached) users to existing global usernames
T16862: Allow global renaming of global users
Reference
bz35707
There are a very large number of changes, so older changes are hidden. Show Older Changes
Az1568 added a subscriber: Az1568.Feb 14 2015, 2:41 AM
Ricordisamoa added a subscriber: Ricordisamoa.
KTC added a subscriber: KTC.Feb 19 2015, 1:27 PM
Eloquence moved this task from Unscheduled to August 2015 on the Roadmap board.
Dcljr added a subscriber: Dcljr.Mar 6 2015, 12:29 AM
Harej added a subscriber: Harej.Mar 17 2015, 6:48 AM
Restricted Application added a project: Notice. · View Herald TranscriptApr 2 2015, 7:58 PM
gpaumier moved this task from Backlog to Triaged on the Notice board.

Just to followup re: timescales for the casual bugspam follower, it's looking more like the first quarter of 2015 for this than 2016 (source: Dan Garry).

Yes, I'm told this (near?) completion of account unification will happen in April 2015.

Just to followup re: timescales for the casual bugspam follower, it's looking more like the first quarter of 2015 for this than 2016 (source: Dan Garry).

Yes, I'm told this (near?) completion of account unification will happen in April 2015.

Indeed. The Great Renaming of 2015 is scheduled to begin on or around 15 April 2015.

IIRC, other than T73241, we have not sent any real email notification to the accounts in question. The only emails were Echo's undecipherable enotiftalk. I think affected users should receive at least one email on the matter at least one week before the renames.

Should/can we do a final sendConfirmAndMigrateEmail.php run over *all* email addresses (confirmed or not, owned by a global account or not) of all usernames with unattached accounts?

  • Original Message -----

Tgr added a blocked task: T74469: OAuth: Authorisation should not fail
because you don't have an account on central wiki.

TASK DETAIL
https://phabricator.wikimedia.org/T37707

REPLY HANDLER ACTIONS
Reply to comment or attach files, or !close, !claim, !unsubscribe or !assign
<username>.

EMAIL PREFERENCES
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Legoktm, Tgr
Cc: Asahiko, Harej, DerHexer, Dcljr, KTC, Alchimista, Shanmugamp7,
Ricordisamoa, jeremyb, Az1568, Rdicerb, -jem-, Liuxinyu970226, Stefan2,
Jdforrester-WMF, MarcoAurelio, Krenair, matmarex, Elitre, Legoktm, Nemo_bis,
Scott, waldyrious, Addshore, Merl, jayvdb, PiRSquared17, MarkAHershberger,
Denny, Jarry1250, Revi, Glaisher, bd808, Deskana, Rschen7754, Platonides,
MZMcBride, Quiddity, Bencmq, Aklapper, Pcoombe, DanielFriesen, Keegan,
Catrope, RobLa-WMF, Trijnstel, Mabdul, MF-Warburg, Reedy, Stryn,
Dinoguy1000, hoo, vvv, gpaumier, Se4598, Jay8g

IIRC, other than T73241, we have not sent any real email notification to the accounts in question. The only emails were Echo's undecipherable enotiftalk. I think affected users should receive at least one email on the matter at least one week before the renames.

Should/can we do a final sendConfirmAndMigrateEmail.php run over *all* email addresses (confirmed or not, owned by a global account or not) of all usernames with unattached accounts?

Based on the immediate response rate after the last ConfirmAndMigrate pass, as well as the response to the talk page notifications, I'm fairly convinced that another email pass is not necessary and that we've reached account holders who are likely to visit their accounts or check their email within a month. Those stats will be available again in graphic form when we can unbreak the graph from the spikes :) I'll see about getting another SUL audit update on mw.org.

gpaumier moved this task from Triaged to Archive on the Notice board.Apr 9 2015, 5:45 PM
Eloquence moved this task from April 13-17 to April 20-24 on the Roadmap board.Apr 21 2015, 5:41 AM

\o/ https://lists.wikimedia.org/pipermail/wikimedia-l/2015-April/077623.html nearly all the renames are done, but this bug should stay open until $wgCentralAuthStrict = true on the cluster.

bd808 awarded a token.Apr 22 2015, 4:00 PM

\o/ https://lists.wikimedia.org/pipermail/wikimedia-l/2015-April/077623.html nearly all the renames are done, but this bug should stay open until $wgCentralAuthStrict = true on the cluster.

On svwiki, Special:UsersWhoWillBeRenamed still lists lots of user names, and there is one user with zero-length user name on dewiki. On the other hand, the special page doesn't list anyone on enwiki or jawiki. Is this intentional?

Harej awarded a token.Apr 22 2015, 6:55 PM

there is one user with zero-length user name on dewiki.

T5507?

there is one user with zero-length user name on dewiki.

T5507?

Likely. Legoktm is going to resolve that when he gets back next week. Pretty much all he has to do is reconfigure Maintenance script and run it. There's other database cleanup stuff left to do, but for now we're 99.99995% complete, account-wise.

greg added a subscriber: greg.May 16 2015, 5:31 AM

there is one user with zero-length user name on dewiki.

T5507?

Likely. Legoktm is going to resolve that when he gets back next week. Pretty much all he has to do is reconfigure Maintenance script and run it. There's other database cleanup stuff left to do, but for now we're 99.99995% complete, account-wise.

Update?

Tbayer added a subscriber: Tbayer.May 26 2015, 8:28 PM

@Legoktm: Could you maybe reply to T37707#1290187 ?

Anybody: Also, is this task really still "Unbreak now" priority now that SUL is pretty much completed, or should the priority be adjusted?

bd808 lowered the priority of this task from "Unbreak Now!" to "High".Jun 15 2015, 3:44 PM

Setting a tracking bug to UBN is not useful generally unless it is tracking a production outage situation.

Meno25 added a subscriber: Meno25.Jul 11 2015, 6:20 AM
Restricted Application added a subscriber: Steinsplitter. · View Herald TranscriptJul 11 2015, 6:20 AM

Change 224510 had a related patch set uploaded (by Legoktm):
Set $wgCentralAuthStrict = true;

https://gerrit.wikimedia.org/r/224510

Change 224510 merged by jenkins-bot:
Set $wgCentralAuthStrict = true;

https://gerrit.wikimedia.org/r/224510

Change 224510 merged by jenkins-bot:
Set $wgCentralAuthStrict = true;

https://gerrit.wikimedia.org/r/224510

This was reverted in rOMWC24581d360ca3: Revert "Set $wgCentralAuthStrict = true;" because our logging wasn't working properly. https://gerrit.wikimedia.org/r/#/c/224540/ should fix the logging, so we'll try again on Wednesday.

Legoktm closed this task as "Resolved".Jul 15 2015, 3:50 PM

Ok, tried it again today and strict mode is working and logging properly! Sent a notification to wikitech-l and wikitech-ambassadors: https://lists.wikimedia.org/pipermail/wikitech-l/2015-July/082396.html

Going to close this as resolved as nearly all accounts have been unified (the exceptions are being tracked individually). There is still pending work with the deployment of the global user merge tool, but that is being tracked separately.

\o/

Harej added a comment.Jul 15 2015, 3:52 PM

*FIREWORKS*

Meno25 removed a subscriber: Meno25.Jul 15 2015, 3:57 PM

I don't know how to react to the pic above... but Lego is certainly the hero of the day!

greg awarded a token.Jul 15 2015, 4:22 PM

And not with a bang, but a whimper.

To all who have worked on this project over the past decade: thank you, thank you, thank you.

Keegan moved this task from Doing to Done on the SUL-Finalization board.Jul 16 2015, 12:04 AM

Add Comment