Page MenuHomePhabricator

Article Feedback Page - 'Mark as Resolved' should be 'Unmark as Resolved'
Closed, ResolvedPublic

Description

Feedback Page Resolved Bug

After a user marks a post as resolved on the feedback page, the link name should change from 'Mark as Resolved' to 'Unmark as Resolved' in the tools panel. The next editor who visits that page should also be able to see this 'Unmark as Resolved' link and click on it to un-mnark the post.

In the attached screenshot from prototype, the last item shows a label saying that it has been resolved, but doesn't show the 'Unmark as Resolved' link. This should be fixed.

Also, the attached screenshot shows other anomalies:

  • The timestamp should not say '42 years ago'. It's possible that this post was made last year, which could be causing this strange artifact.
  • There seems to be an error in the counters for 'flag as abuse' posts. I personally flagged the last post in the screenshot, bringing its flag count to 3, which turns it red. But I believe that this red flag with the number of 3 is showing up incorrectly in the previous post above it, rather than in the last post where it belongs.

Version: unspecified
Severity: major

Attached:

Details

Reference
bz36207

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 12:21 AM
bzimport added a project: ArticleFeedbackv5.
bzimport set Reference to bz36207.

elizabeth wrote:

I cannot replicate the additional anomalies - please open bugs for them if you can reproduce the issue

The mark as resolved item has been fixed and pushed to omniti

elizabeth wrote:

Pushed to prototype and tested