Page MenuHomePhabricator

Diff incorrectly reports incorrect line numbers
Closed, ResolvedPublic

Description

Author: frazzleddad

Description:
Line number is off when showing changes

When using "Show Changes" the line number is off by one.

Safari 5.1.5 on OSx Lion.

http://en.wikisource.org/w/index.php?title=Page:The_book_of_try_and_learn.djvu/1&action=submit

Repro: Edit page, change text on first line. Click "Show Changes".

Expected: Line Number at top should show Line 1
Actual: Line number shows Line 2


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz36552

Related Objects

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:25 AM
bzimport added a project: ProofreadPage.
bzimport set Reference to bz36552.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.May 5 2012, 6:15 PM

Also, the </noinclude> is exposed.

Moving to Proofread Extension. This is not a bug in MediaWiki core, which does everything just fine (try it on a simple sandbox page).

The proofread extension is using some hacky javascript implementation that, when the page loads, removes part of the javascript and puts it back in when submitting the form. That first line isn't miscalculated, it is really there.

GOIII added a comment.Aug 30 2014, 2:35 AM

I can't reproduce this effect no matter if my Prefs are set to show or hide the Proofread Page: header & footer fields first.

I think this resolved (inadvertently) with the refactoring of the extension back in January ( Bugzilla 46616 ).

GOIII claimed this task.Jul 11 2015, 8:10 AM
GOIII added a subscriber: GOIII.

This issue was resolved back when the Page: namespace's diff layout was changed to address all three possible "fields" (i.e. textareas better known as header, body & footer). Closing

GOIII closed this task as Resolved.Jul 11 2015, 8:11 AM
GOIII moved this task from Backlog to Done on the ProofreadPage board.Jun 12 2016, 3:44 AM