It seems that on clusters that have never had a helm deployment at all skaffold is unable to run in it's helm configuration. This is now the case on fresh development clusters that have only had services deployed using argo-cd
Workarounds
A quick work around is available at https://github.com/wmde/wbaas-deploy/pull/1955 which uses raw kubectl. Unfortunately this work around only works with changes to the image and doesn't include updates to the charts.
Another work around recommended by @dena is to make helm deployment happen is to:
Re-Add the API helm release back into helmfile.yaml: https://github.com/wmde/wbaas-deploy/blob/main/k8s/helmfile/only-for-argo-value-generation.yaml#L51-L55
Since this release will exist before the one that Argo deploys, it will be possible to replace via skaffold
Re-Create your local cluster
Run make skaffold-api