Page MenuHomePhabricator

Bring beta-logs.wmcloud.org to a readable state
Closed, DeclinedPublic

Description

Beta cluster logstash is filled to the brim with random errors coming from all over the place. It's extremely hard to navigate and to find the useful stuff. For example, for the last 60 minutes, we have:

  • 48k instances of "PHP Warning: preg_match(): Compilation failed: unrecognised compile-time option bit(s) at offset 0 in /srv/mediawiki/php-master/includes/libs/http/MultiHttpClient.php on line 722" (see T387276)
  • 24k instances of "PHP Warning: EtcdConfig failed to fetch data: (curl error: 6) Couldn't resolve host name in /srv/mediawiki/php-master/includes/config/EtcdConfig.php on line 204" (exactly half of the above, so likely related)
  • 13k errors with no normalized_message or message fields for "Error: getaddrinfo ENOTFOUND prometheus-labmon.eqiad.wmnet"
  • 13k "Pool key 'CirrusSearch-Search:_elasticsearch' (CirrusSearch-Search): ⧼poolcounter-connection-error⧽"
  • 4k "Exec error in changeprop"

...and many more. Some of these are probably just different symptomps of the same underlying cause (like jobs seemingly not being run: T387631).

Ideally, these should be fixed or hidden to bring the error level to an acceptable state.

Event Timeline

As written I don't think this task is actionable. "Fix all of the code so it stops logging errors" is not within the scope of the tiny handful of folks who look at infrastructure things in deployment-prep.

Yeah, that's why I was being vague and said "ideally". I don't think it needs to be a "fix everything" either, it's fine if there are some errors. It's more about the current state having occasional traces of useful data in an ocean of noise. I'm also curious to see what happens once the current issues with deployment-jobrunner05 are resolved, as some of these errors seem related.

I'm also curious to see what happens once the current issues with deployment-jobrunner05 are resolved, as some of these errors seem related.

Indeed, many of those errors are gone. As for what remains:

  • cxserver log messages don't use normalized_message, so they're a bit harder to filter. Filed T389273.
  • CirrusSearch poolcounter stuff: can also be seen in production at a rate of ~10k errors/hour. These caused an UBN in production in 2023: T352444. Taking a closer look though, the log level is INFO, so despite the word "error" in the message, these might be harmless?!
  • "Exec error in changeprop": T389252 tracks errors due to a missing parsoid service. I filed T389274 for those originating from wikifunctions.

And that should be everything for the >1000/h category.

bd808 renamed this task from Bring beta cluster logstash to a readable state to Bring beta-logs.wmcloud.org to a readable state.Sep 17 2025, 8:13 PM

The biggest normalized bucket right now is "Pool key 'CirrusSearch-Search:_elasticsearch' (CirrusSearch-Search): ⧼poolcounter-connection-error⧽" which is pretty obviously related to T380881: Re-create poolcounter instance in Beta Cluster (deployment-prep).

The next highest are "Failed to write logs to file" and "worker died, restarting" from CXServer.

ChangeProp is spamming "Commit failed" messages.

I am going to close this as declined. I do think fixing broken things in Beta Cluster is worthwhile, but I do not feel this task is directly actionable or useful as an aggregate tracking task.