Page MenuHomePhabricator

OH-AFT "Improve this page" feedback widget shows "Remove this tool?" X only in Firefox
Closed, InvalidPublic

Description

Author: wikimedia-bz

Description:
AFTv5 "Improve this page" widget in Firefox 3.5.16

Description:

When I visit a page with AFTv5 enabled, eg: http://en.wikipedia.org/wiki/Golden-crowned_Sparrow?aftv5_form=1&aftv5_link=E

...In Firefox 3.6.28/OS X 10.4.11 and Iceweasel 3.5.16/Debian Squeeze, the "Improve this page" article feedback widget that shows in the lower right-hand corner of articles has an "X" that pops up a "Remove this tool?" speech bubble when clicked.

The other browsers I checked (Camino/OS X 10.4.11, Safari 4.1.3/OS X 10.4.11, Chrome 19.0.1084.56 m/WinXP) have the widget, but it doesn't have the "X".

Expected: Widget looks similar and provides the same functionality in all browsers.

Additionally, I notice that when I view what I presume is "version D" of the AFTv5 link in Firefox, the X disappears as well, making it the same as the other browsers.

eg: http://en.wikipedia.org/wiki/Golden-crowned_Sparrow?aftv5_form=1&aftv5_link=D


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz37426

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:22 AM
bzimport added a project: ArticleFeedbackv5.
bzimport set Reference to bz37426.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 9 2012, 6:14 PM

wikimedia-bz wrote:

AFTv5 "Improve this page" widget in Chrome/WinXP

Attached:

Additionally, I notice that when I view what I presume is "version D" of the
AFTv5 link in Firefox, the X disappears as well, making it the same as the
other browsers.

That's the case now - I cannot see a way to close the "Improve the page" area in the bottom right corner.
If this is by design, this bug should be closed as INVALID.

Have to correct myself: http://en.wikipedia.org/wiki/Drew_Barrymore?aftv5_form=1&aftv5_link=E shows an X to close in Firefox 17, aftv5_link=D does not.
aftv5_link=E does not show an X to close in Opera 11.

In opera the X to close is there too, if a user is logged in.

It will only be displayed to logged in users because it will show a message that it can be disabled in preferences, so it makes no sense to show it that to anon users.

D indeed has no "close" link, for neither anons or logged in.