Page MenuHomePhabricator

migrates Apaches boxes to precise
Closed, ResolvedPublic

Description

beta Apaches have been installed using Lucid. To generates thumbnails of videos, we need them to use the latest ffmpeg packages (bug 37217).

This bug is about phasing out Apaches running Lucid and installing new ones based on Precise.


Version: unspecified
Severity: normal

Details

Reference
bz37500

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:28 AM
bzimport set Reference to bz37500.
hashar created this task.Jun 12 2012, 12:41 PM

I have created two instances:

  • deployment-apache30
  • deployment-apache31

Configured both instances to use puppet classes applicationserver::labs and imagescaler::labs just like the apache20-24 instances.

(In reply to comment #0)

beta Apaches have been installed using Lucid. To generates thumbnails of
videos, we need them to use the latest ffmpeg packages (bug 37217).

Aren't jobrunners the only ones to generate the thumbnails?

(In reply to comment #3)

Aren't jobrunners the only ones to generate the thumbnails?

That is the case in production. In beta though, thumbnails are generated through a call to /w/thumbs.php which is served by the apaches.

Still need to fix the packages. Several packages were renamed between Lucid and Precise such as language-support-fonts-*

We had the same issue with Hardy -> Lucid upgrade, see https://gerrit.wikimedia.org/r/11298 that removes Hardy support.

Failing packages:

Dependency Package[language-support-fonts-mn] has failures: true
Dependency Package[language-support-fonts-th] has failures: true
Dependency Package[language-support-fonts-mr] has failures: true
Dependency Package[language-support-fonts-ar] has failures: true
Dependency Mount[/mnt/thumbs] has failures: true
Dependency Package[language-support-fonts-ii] has failures: true
Dependency Package[language-support-fonts-ko] has failures: true
Dependency Package[gs] has failures: true
Dependency Package[language-support-fonts-fa] has failures: true
Dependency Package[language-support-fonts-my] has failures: true
Dependency Package[language-support-fonts-am] has failures: true
Dependency Package[language-support-fonts-lo] has failures: true
Dependency Package[language-support-fonts-te] has failures: true
Dependency Package[language-support-fonts-zh] has failures: true
Dependency Package[language-support-fonts-ja] has failures: true
Dependency Package[language-support-fonts-bn] has failures: true
Dependency Package[language-support-fonts-ne] has failures: true
Dependency Package[language-support-fonts-ml] has failures: true
Dependency Package[language-support-fonts-el] has failures: true
Dependency Package[language-support-fonts-or] has failures: true
Dependency Package[language-support-fonts-as] has failures: true
Dependency Package[language-support-fonts-gu] has failures: true
Dependency Package[language-support-fonts-yi] has failures: true
Dependency Package[language-support-fonts-km] has failures: true
Dependency Package[language-support-fonts-ur] has failures: true
Dependency Package[language-support-fonts-he] has failures: true
Dependency Package[language-support-fonts-mnc] has failures: true
Dependency Package[language-support-fonts-ta] has failures: true
Dependency Package[language-support-fonts-kn] has failures: true
Dependency Package[language-support-fonts-dz] has failures: true
Dependency Package[language-support-fonts-bo] has failures: true
Dependency Package[language-support-fonts-hi] has failures: true
Dependency Package[language-support-fonts-pa] has failures: true
Dependency Package[wikimedia-fonts] has failures: true

https://gerrit.wikimedia.org/r/11358 to expand language-support-fonts-* packages on Precise

https://gerrit.wikimedia.org/r/11359 rename gs to ghostscript

Both changes merged in test branch. Still Need to update production branch though, lowering priority.

The production and test branches have been merged this week by Ryan Lane. I have checked the imagescaler.pp file, and it received the updates referenced in comment #7.

So this is finally fixed. The 'beta' Apaches do run Precise.