Page MenuHomePhabricator

Handling for missing language codes
Closed, InvalidPublic

Description

Handling for missing language codes is needed.

http://wikidata-test-repo.wikimedia.de/wiki/Data:Q24788 shows some entries w/o language names/codes.


Version: master
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=37542
https://bugzilla.wikimedia.org/show_bug.cgi?id=42396

Details

Reference
bz37754

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 12:24 AM
bzimport set Reference to bz37754.
bzimport added a subscriber: Unknown Object (MLST).
Raymond created this task.Jun 20 2012, 6:41 PM

If we have a sitelink using a a site identifier that is not in the site list (anymore), then hide the sitelink from the UI.

Before closing, add a bug for a maintenance script that removes such sitelinks.

*** Bug 37826 has been marked as a duplicate of this bug. ***

Denny added a comment.Aug 2 2012, 9:48 AM

It is being shown now with the code only (since the sitename is not available).

Denny added a comment.Aug 2 2012, 9:51 AM

Check how the UI behaves. Check if sites are removable without having a code.

  • Bug 44002 has been marked as a duplicate of this bug. ***
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 16 2015, 5:51 AM
adrianheine closed this task as Invalid.Jan 20 2016, 1:54 PM
adrianheine claimed this task.
adrianheine added a subscriber: adrianheine.

Too generic and probably done.