Page MenuHomePhabricator

empty wgScriptPath make exporting to PDF fail
Closed, ResolvedPublic

Description

Author: Coiby.Xu

Description:
The error log:
RuntimeError: RuntimeError: command failed with returncode 256: ['mw-zip', '-o', '/b3/b33ef36ef3bb7840/collection.zip', '-m', '/b3/b33ef36ef3bb7840/metabook.json', '--status', 'qserve://localhost:14311/b33ef36ef3bb7840:makezip', '--template-blacklist', 'MediaWiki:PDF Template Blacklist', '--template-exclusion-category', u'\u6253\u5370\u65f6\u6392\u9664', '--print-template-prefix', u'\u6253\u5370', '--print-template-pattern', u'$1\uff0f\u6253\u5370', '--username', 'coiby', '--password', '{OMITTED}'] Last Output: 2012-06-23T23:07:32 mwlib.options.warn >> Both --print-template-pattern and --print-template-prefix (deprecated) specified. Using --print-template-pattern only. 1% creating nuwiki in u'/b3/b33ef36ef3bb7840/tmpEmnFC1/nuwiki' removing tmpdir u'/b3/b33ef36ef3bb7840/tmpEmnFC1' memory used: res=11.0 virt=19.9 1% error Traceback (most recent call last): File "/usr/bin/mw-zip", line 9, in <module> load_entry_point('mwlib==0.13.8', 'console_scripts', 'mw-zip')() File "/usr/lib/python2.6/site-packages/mwlib-0.13.8-py2.6-linux-i686.egg/mwlib/apps/buildzip.py", line 155, in main make_zip(output, options, env.metabook, podclient=podclient, status=status) File "/usr/lib/python2.6/site-packages/mwlib-0.13.8-py2.6-linux-i686.egg/mwlib/apps/buildzip.py", line 50, in make_zip make_nuwiki(fsdir, metabook=metabook, options=options, podclient=podclient, status=status) File "/usr/lib/python2.6/site-packages/mwlib-0.13.8-py2.6-linux-i686.egg/mwlib/apps/make_nuwiki.py", line 152, in make_nuwiki assert x.wikiident in id2wiki, "no wikiconf for %r (%s)" % (x.wikiident, x) AssertionError: no wikiconf for None (<article {'_env': <mwlib.wiki.Environment object at 0x9fc448c>, 'content_type': u'text/x-wiki', 'title': u'\u9996\u9875', 'timestamp': u'1340295690', 'type': 'article', 'revision': u'525'}>) in function system, file /usr/lib/python2.6/site-packages/mwlib-0.13.8-py2.6-linux-i686.egg/EGG-INFO/scripts/nslave.py, line 63 in function qaddw, file /usr/lib/python2.6/site-packages/qserve-0.2.7-py2.6.egg/qs/slave.py, line 66


Version: unspecified
Severity: major
URL: https://github.com/pediapress/Collection/issues/1
See Also:
https://github.com/pediapress/Collection/issues/1

Details

Reference
bz37868

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 12:22 AM
bzimport added a project: Collection.
bzimport set Reference to bz37868.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 23 2012, 5:01 PM
saper added a comment.Jun 23 2012, 6:48 PM

Many reports

Coiby.Xu wrote:

Thanks! This workaround is nice.

Also reported in https://github.com/pediapress/Collection/issues/1 with a
workaround

Change 87293 had a related patch set uploaded by Bpetty:
Fix doc generation for use with root MediaWiki configs and short URLs.

https://gerrit.wikimedia.org/r/87293

saper added a comment.Oct 3 2013, 10:47 PM

I think that the real bug is caused by r103208 which changed wfExpandUrl not to expand "".

  • Bug 38187 has been marked as a duplicate of this bug. ***

Change 87293 had a related patch set uploaded (by Cscott):
Generate PDFs if $wgScriptPath is empty

https://gerrit.wikimedia.org/r/87293

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 7:49 PM

Change 87293 merged by jenkins-bot:
Generate PDFs if $wgScriptPath is empty

https://gerrit.wikimedia.org/r/87293

Arlolra closed this task as Resolved.Nov 13 2015, 9:31 PM
Arlolra claimed this task.