The error occurs while upgrading a database from a mediawiki from 1.39.4 to 1.43.3. Since this error was resolved in T330382, I dont know what to do. My configurations are:
| MediaWiki | 1.43.3 |
| PHP | 8.3.19 (fpm-fcgi) |
| ICU | 67.1 |
| PostgreSQL | 14.18 |
The code below relates the error that occured:
..site_type key doesn't exist. ...iwl_prefix_from_title key doesn't exist. ...pagelinks table has already been migrated. ...column 'revision.rev_id' is already of type 'BIGINT' ...column 'revision.rev_parent_id' is already of type 'BIGINT' ...column 'recentchanges.rc_id' is already of type 'BIGINT' ...column 'change_tag.ct_rc_id' is already of type 'BIGINT' Running MigrateBlocks... ...Update 'MigrateBlocks' already logged as completed. Use --force to run it again. done. ...ipblocks doesn't exist. Table pagelinks contains pl_title field. Dropping... An error occurred: Error 42704: ERROR: index "pl_namespace" does not exist
Edit: After some test with the database, the index pl_namespace was found and the update procceded. We stuck with the error "RROR: constraint "pagelinks_pkey" of relation "pagelinks" does not exist". The resolution is to download a newer version of the 1.43.3.