Page MenuHomePhabricator

Make $wgTranslateSupportUrl configurable by namespace/project
Closed, ResolvedPublic

Description

As wiki owner, I want the support requests to go directly to the relevant projects' pages (with their managers and possibly queues) so that they're handled by the responsible people instead of cluttering a central page nobody is clearly responsible (or able to take care) of.


The target of the "ask" button should not be forced to be a single support page for the entire wiki.

Note that Niklas disagrees this should be done on translatewiki.net, he prefers TWN staff to vet all issues and immediately act on them when possible/needed (if I understood correctly). Not marking directly WONTFIX to sleep over it.


Version: master
Severity: enhancement
URL: https://translatewiki.net/w/i.php?title=Support&diff=prev&oldid=4035659

Details

Reference
bz38635

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 12:58 AM
bzimport set Reference to bz38635.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Jul 24 2012, 9:44 AM

The only downside currently is moving the issue to the correct page (which doesn't send email notification because LQT bug). As bonus the reporters can get some instant gratification that someone has noticed their question (not worth much?) and if the issue is about something the twn staff needs to do, it doesn't need to be moved. We also get overview of issues coming in.

Either way some issues would need to be moved after reporting.

(In reply to comment #1)

The only downside currently is moving the issue to the correct page (which
doesn't send email notification because LQT bug).

This is a big downside, the [[Support]] page becomes unreadable with the long list of issues, as you often notice. LQT bug/feature or not, this also fills it with placeholders and this is not going to change.

Niklas clarified what he means https://translatewiki.net/w/i.php?title=Support&oldid=4035659&diff=4038120
If everything has to be moved anyway it's even harder for me to understand why not to put it in the correct talk in the first place, but it's a choice.

Nemo_bis updated the task description. (Show Details)
Nemo_bis set Security to None.
Nemo_bis added a subscriber: Pxos.May 14 2015, 9:53 AM
Nemo_bis claimed this task.Sep 5 2015, 12:34 PM

Maybe there is hope:

2015-08-19 10.21 < Nemo_bis> project as defined by namespace
2015-08-19 10.22 <@Nikerabbit> Nemo_bis: sounds reasonable
2015-08-19 10.23 <@Nikerabbit> (that is yes)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 5 2015, 12:34 PM

Change 236259 had a related patch set uploaded (by Nemo bis):
Refactor $wgTranslateSupportUrl constructions

https://gerrit.wikimedia.org/r/236259

Change 236260 had a related patch set uploaded (by Nemo bis):
Allow external or per-namespace support URL

https://gerrit.wikimedia.org/r/236260

Not tested yet. Example usage for translatewiki.net, based on the responses to the recent support requests and cleanup thereof: https://gerrit.wikimedia.org/r/236264 .

Change 236259 merged by jenkins-bot:
Refactor $wgTranslateSupportUrl constructions

https://gerrit.wikimedia.org/r/236259

Change 236260 merged by jenkins-bot:
Allow external or per-namespace support URL

https://gerrit.wikimedia.org/r/236260

Nemo_bis closed this task as Resolved.Sep 5 2015, 6:42 PM

That was fast! Thanks Niklas.

Nemo_bis rescinded a token.Jul 16 2016, 8:00 AM