Page MenuHomePhabricator

Update jQuery to 1.8.1
Closed, ResolvedPublic

Description

Author: steefy389

Description:
Please update jQuery from 1.8.0 to 1.8.1, as 1.8.0 introduced a regression where selectors with class and id, like $('#ca-talk.new a'), returned wrong elements (see http://bugs.jquery.com/ticket/12439). This already broke a script in dewiki (https://de.wikipedia.org/w/index.php?title=MediaWiki:Common.js&diff=107497820&oldid=106542964). I guess that there are more scripts affected, where this problem isn't as obvious.


Version: unspecified
Severity: major

Details

Reference
bz39908

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:57 AM
bzimport set Reference to bz39908.
Reedy added a comment.Sep 2 2012, 1:43 PM

1.20wmf10 in https://gerrit.wikimedia.org/r/#/c/22366/

But I can't check it out on fenari currently. Rage.