Page MenuHomePhabricator

Please give me my accounts back
Closed, ResolvedPublic

Description

Hello,

Yesterday I was checking https://toolserver.org/~quentinv57/sulinfo/MarcoAurelio and I noticed a large list of accounts that were mine but appeared as unnatached, so I went to https://meta.wikimedia.org/w/index.php?title=Special%3ACentralAuth&target=MarcoAurelio to see the real data and everything was fine (no unnatached accounts). However when I tried to log in to bnwiki (one of the wikis that appeared as unnatached in Q's tool), I was unable to and I get a "password error" message.

At some, such as https://sl.wikiquote.org/wiki/Posebno:Dnevnik/MarcoAurelio?uselang=en I have steward-logs that demonstrates that once I had normal access to them.

I'd like to note again that those accounts are mine. They once appeared at Special:CentralAuth but now they're out of the table for I don't know why reasons.

List of accounts that do belong to me and were SUL created but that I can't log-in to there anymore, nor my password works.

  • bnwiki
  • foundationwiki
  • newwiki
  • nywiki
  • siwiki
  • siwiktionary
  • slwikiquote
  • slwiktionary
  • smwiki
  • smwiktionary

Can you manualy merge those again to my SUL?

Thank you.


Version: unspecified
Severity: major

Details

Reference
bz39997

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 1:04 AM
bzimport set Reference to bz39997.

Ruslik00 wrote:

foundationwiki is outside SUL. Other accounts have noedits. So, the simplest solution is to "usurp" (rename) them and then recreate them automatically.

(In reply to comment #1)

foundationwiki is outside SUL. Other accounts have noedits. So, the simplest
solution is to "usurp" (rename) them and then recreate them automatically.

Yes, I agree that's the simplest solution but the issue that caused this will still need to be investigated. Regards.

  • This bug has been marked as a duplicate of bug 39996 ***

Actually when trying to reset the password for, ie, https://sm.wiktionary.org/wiki/Special:Log/MarcoAurelio [which as you can see it was created automatically], I get the following error message:

<< There is no e-mail address recorded for user "MarcoAurelio" >>

My global account and local accounts have an email set. So it seems that when the account was autocreated there the system forgot to record it as well. A root user should manually add it so I can reset the password and later using MergeAccount, re-unify it. Is that possible?

It is possible. I'll work on this today for all of the accounts (like smwikitionary) where you have admin actions. And hopefully I'll be able to hunt down some of *why* this happened too..

Marco, I added an email address to your accounts on:

  • newwiki
  • siwiki
  • siwiktionary
  • slwikiquote
  • slwiktionary
  • smwiki
  • smwiktionary

So you can go and reset your passwords there, and merge them. I can do the other ones too, but since there wasn't steward-level activity in the log, I'm not sure who needs to give approval for that.

For the larger issue of why:

  • On all these wikis, there was a user account with the name MarcoAurelio, with no email address and no password.
  • For all these wikis, there was no entry in centralauth.localuser or centralauth.localnames for MarcoAurelio

So it looks like SpecialUserlogin::initUser() runs the first $u->addToDatabase() to put the default user object into the db, but before it reaches $u->saveSettings() (24 lines later), something happens. Since the centralauth tables weren't updated either, it might be that $wgAuth->initUser( $u, $autocreate ); wasn't run either.

Thank you very much Chris. I still have issues with smwiktionary, which I'm not able to reset.

As for MarcoAurelio@bnwiki, it is also mine: https://bn.wikipedia.org/wiki/%E0%A6%AC%E0%A6%BF%E0%A6%B6%E0%A7%87%E0%A6%B7:Log/MarcoAurelio?uselang=en

The same for MarcoAurelio@nywiki: https://ny.wikipedia.org/wiki/Special:Log/MarcoAurelio?uselang=en

Thanks in advance for your help.

Chris, the accounts I've just recovered do not appear at the CentralAuth table at https://meta.wikimedia.org/w/index.php?title=Special%3ACentralAuth&target=MarcoAurelio - something wrong going on over there too. Best regards.

Marco, you will need to attach them to your CentralAuth account by going to https://meta.wikimedia.org/wiki/Special:MergeAccount and putting in your password for each one.

Let me know if they still don't show up on CentralAuth after that.

On smwiktionary, I just checked and your email is set. Did you get an error message? Or just no email?

(In reply to comment #9)

Marco, you will need to attach them to your CentralAuth account by going to
https://meta.wikimedia.org/wiki/Special:MergeAccount and putting in your
password for each one.
Let me know if they still don't show up on CentralAuth after that.

I tried that but at Meta and other projects but Special:MergeAccount didn't showed those unnatached accounts. I had to access the MergeAccount form from the project I just recovered the account. I was very weird...

On smwiktionary, I just checked and your email is set. Did you get an error
message? Or just no email?

No email at all. A fellow steward tried to reset the password too, unsuccessfully.

Thanks.

For bnwiki, there is already a verified email and password set for the account. Email starts with 'wmd'...

I'll go ahead and add your email to nywiki. The account has no edits, and if Marco wanted to usurp another user's account, he could do it himself.

That 'wmd' email is the old email address I used for Wikimedia. I changed it globally well over a year ago. Perhaps when the account got misteriously detached it reset to the email it had at the first time.

That email account is closed and deleted, so I can not access it anymore. If you could change that as well I'll be most grateful.

Best regards.

nywiki has been updated too.

(In reply to comment #13)

nywiki has been updated too.

Account recovered, thanks. I've not merged it for now so you can look if you want why it doesn't appear at MergeAccount nor CentralAuth. Best regards.

Marco, I think I was able to successfully send a reset email for smwiktionary. Let me know if you have trouble accessing it. I found the reason for your account not showing up in CentralAuth as an unmerged account-- it had to do with the account creation being aborted, so your username + wiki wasn't in the localnames table. But it sounds like merging the account from the local wiki is working, so I'm going to close this as fixed. Apologies this took so long!

Regained access to smwiktionary. Thank you very much for your help. Best regards.