Release notes of potential interest (1.36.0, 1.37.0, 1.38.*):
- maximum concurrent http2 streams per connection default changed
- http default reset code changed
- Minimum acceptable TLS version is 1.0 and maximum is 1.3 as of 1.39.0
Once the upgrade is complete, we will be able to configure one or both of:
- max_udp_channel_duration: The maximum duration for which a UDP channel will be kept alive before being refreshed.
- reinit_channel_on_timeout: If true, reinitialize the c-ares channel when a DNS query fails with ARES_ETIMEOUT.
Either one would have circumvented what we saw in T421343: Some traffic still flowing to mw-api-int after the switchover