Page MenuHomePhabricator

New edit warning above the editing window should be dismissible
Closed, DeclinedPublic

Description

MediaWiki:Editpage-head-copy-warn was created to allow moving the warning that was previously shown below the edit window above it, per https://www.mediawiki.org/wiki/Micro_Design_Improvements

This actually makes the warning significantly more prominent than before, which is a good thing in that it'll actually be noticed, but it's pretty in-your-face for something that every Wikimedian understands after a while.

As a further iterative improvement, I would suggest making the warning dismissible (perhaps with a link with a friendly label like "Thanks, got it"). Ideally this should be persistent via the preferences API so it doesn't keep coming back if a cookie expires.

This change requires legal sign-off.


Version: 1.21.x
Severity: normal

Details

Reference
bz40692

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:55 AM
bzimport set Reference to bz40692.
bzimport added a subscriber: Unknown Object (MLST).
Eloquence created this task.Oct 2 2012, 1:57 AM

I agree that it'd be nice to be able to dismiss this warning. I'm not sure why the dismissibility has to be conditional on the use of JavaScript, though.

You're right, this was more intended in the "at a minimum" sense - but if we use a persistent pref rather than Yet Another Cookie, we get non-JS dismissibility for free, at the cost of some additional pref clutter. Amending summary.

Yeah, the additional pref clutter is what I'm worried about; we're expected to dramatically slim down the prefs section for Echo. Perhaps we could just tie it to some sort of user status? Like, if we're talking "after a while, they know how to do it" - when an account has made N edits, or gets any userright other than autoconfirmed (or gets autoconfirmed itself) we assume they're far enough down the rabbit-hole to know that {{cn}} should be avoided. This is just me spitballing, note.

I don't think legal actually needs to sign off: this isn't their text (they own the "You agree..." section). The only bit that has legal implications is "please don't violate teh copyrights" and that's duplicated, for all intents and purposes, in the TOS, which says (Section 4) "Certain activities, whether legal or illegal, may be harmful to other users and violate our rules, and some activities may also subject you to liability. Therefore, for your own protection and for that of other users, you may not engage in such activities on our sites. These activities include...Infringing copyrights, trademarks, patents, or other proprietary rights under applicable law."

Users are, of course, required to accept this before hitting "save" (and hitting save is taken to be an acceptance of it).

The perfect is the enemy of the good. Let's make it dismissible with pref for now.

TheDJ changed the task status from Open to Stalled.Dec 21 2015, 8:11 PM
TheDJ added a subscriber: TheDJ.

I had forgotten it was even there. I have had it hidden with personal css, on English Wikipedia since forever.

It's also not used in any language other than en.wp. and I have to say that I haven't many seen complaints about this fragment of the edit window either.

Aklapper closed this task as Declined.Fri, May 22, 4:59 PM
Aklapper lowered the priority of this task from Medium to Low.
Aklapper added a subscriber: Aklapper.

7.5 years later I'm boldly declining this. Users on en.wp might be used to this by now and/or are free to add personal CSS to hide it.