Page MenuHomePhabricator

RL module jquery.tipsy should provide an option for DOM-parent
Closed, DeclinedPublic

Description

Current behaviour:

  • If you create a tooltip using tipsy, the tipsy-tooltip-container is appended to document.body

Evidence:
$tip.remove().css({top: 0, left: 0, visibility: 'hidden', display: 'block'}).appendTo(document.body);

  • This leads to a problem with scrollable elements (other than HTLM/body):
    • When you scoll that element, tipsy remains where it is, while the element moves away. Consequently tipsy points to a wrong element
    • When you scoll the body, but have a position:fixed element, tipsy scrolls away while the element remains where it is.

Expected behaviour:

  • Tipsy always points to the right element, despite scrolling etc.

Possible solution:

  • Allow specifying the element, the tipsy-tooltip-container is appended to or do intelligent guessing on it (which will be really challenging, I guess)

Version: unspecified
Severity: minor

Details

Reference
bz41086

Event Timeline

bzimport raised the priority of this task from to Low.
bzimport set Reference to bz41086.
bzimport added a subscriber: Unknown Object (MLST).
Rillke created this task.Oct 16 2012, 4:32 PM
Tgr added a comment.Jul 3 2014, 10:12 PM

Also a problem with fullscreen; the tooltip container is appended to the body, and in fullscreen mode the element on which requestFullscreen() was called basically acts like the body and everything outside it is not rendered, so the tooltips just disappear.

(changing severity since the current fullscreen and scroll behavior is clearly wrong)

Tgr added a comment.Jul 3 2014, 10:14 PM

There is a pull request for the position:fixed issue: https://github.com/jaz303/tipsy/pull/146

Krinkle closed this task as Declined.Aug 30 2017, 5:34 PM

The jquery.tipsy module was deprecated. Declining feature request as it's unlikely new features will be added or considered at this time.