Page MenuHomePhabricator

VisualEditor: Position of VisualEditor's "Create" tab is wrong
Closed, ResolvedPublic

Description

See [[mw:VisualEditor:ThisPageDoesNotExist]].


Version: unspecified
Severity: minor

Details

Reference
bz41159

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 12:58 AM
bzimport set Reference to bz41159.

Old summary: VisualEditor: Position of replacement Edit tab is wrong (to the right of 'Watch' (the star) rather than left)

Updated summary: VisualEditor: Position of "Create" tab is wrong (to the right of 'Watch' [the star] rather than left)

I believe the updated bug summary better reflects the issue in this bug.

For what it's worth, in Monobook it's even goofier.

To reproduce this bug:

  • Set $wgVectorUseIconWatch = true
  • Log in (to have the "watch" right)

It is currently inserted before "ca-history". But on new pages there is no such link, so it falls back to appending to the end.

Fixed in Id88a160621093e4db4cf01c0fa34793cc1a929b4.

(In reply to comment #3)

To reproduce this bug:

  • Set $wgVectorUseIconWatch = true
  • Log in (to have the "watch" right)

It is currently inserted before "ca-history". But on new pages there is no such
link, so it falls back to appending to the end.

Fixed in Id88a160621093e4db4cf01c0fa34793cc1a929b4.

Is it fixed in monobook too? see comment 1.

(In reply to comment #4)

(In reply to comment #3)

Fixed in Id88a160621093e4db4cf01c0fa34793cc1a929b4.

Is it fixed in monobook too?

Yes, it looks fine for me in Monobook.

Code now live in master.