Page MenuHomePhabricator

LQT: Call to a member function getText() on a non-object at Message.php
Closed, DeclinedPublicPRODUCTION ERROR

Description

[18-Oct-2012 18:12:33] Fatal error: Call to a member function getText() on a non-object at /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php on line 632
Server: mw41
Method: POST
URL: http://en.wiktionary.org/w/index.php?title=Talk:domino&action=delete
Backtrace:
#0 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(632): Message::parseText()
#1 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(455): Message->parseText('posted a reply ...')
#2 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(493): Message->toString()
#3 /usr/local/apache/common-local/php-1.21wmf2/extensions/LiquidThreads/classes/Hooks.php(59): Message->parse()
#4 [internal function]: LqtHooks::customizeOldChangesList(Object(OldChangesList), '<a href="/wiki/...', Object(RecentChange))
#5 /usr/local/apache/common-local/php-1.21wmf2/includes/Hooks.php(253): call_user_func_array('LqtHooks::custo...', Array)
#6 /usr/local/apache/common-local/php-1.21wmf2/includes/GlobalFunctions.php(3811): Hooks::run('OldChangesListR...', Array)
#7 /usr/local/apache/common-local/php-1.21wmf2/includes/ChangesList.php(661): wfRunHooks('OldChangesListR...', Array)
#8 /usr/local/apache/common-local/php-1.21wmf2/includes/specials/SpecialRecentchanges.php(528): OldChangesList->recentChangesLine(Object(RecentChange), false, 10)
#9 /usr/local/apache/common-local/php-1.21wmf2/includes/specials/SpecialRecentchanges.php(179): SpecialRecentChanges->webOutput(Object(ResultWrapper), Object(FormOptions))
#10 /usr/local/apache/common-local/php-1.21wmf2/includes/SpecialPage.php(599): SpecialRecentChanges->execute('limit=10')
#11 /usr/local/apache/common-local/php-1.21wmf2/includes/SpecialPageFactory.php(497): SpecialPage->run('limit=10')
#12 /usr/local/apache/common-local/php-1.21wmf2/includes/SpecialPageFactory.php(536): SpecialPageFactory::executePath(Object(Title), Object(RequestContext), true)
#13 /usr/local/apache/common-local/php-1.21wmf2/includes/parser/Parser.php(3366): SpecialPageFactory::capturePath(Object(Title), Object(RequestContext))
#14 /usr/local/apache/common-local/php-1.21wmf2/includes/parser/Preprocessor_DOM.php(1084): Parser->braceSubstitution(Array, Object(PPFrame_DOM))
#15 /usr/local/apache/common-local/php-1.21wmf2/includes/parser/Parser.php(3065): PPFrame_DOM->expand(Object(PPNode_DOM), 0)
#16 /usr/local/apache/common-local/php-1.21wmf2/includes/parser/Parser.php(1150): Parser->replaceVariables('NOEDITSECTION...')
#17 /usr/local/apache/common-local/php-1.21wmf2/includes/parser/Parser.php(378): Parser->internalParse('
NOEDITSECTION...')
#18 /usr/local/apache/common-local/php-1.21wmf2/includes/cache/MessageCache.php(890): Parser->parse('NOEDITSECTION...', Object(Title), Object(ParserOptions), true)
#19 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(632): MessageCache->parse('
NOEDITSECTION...', Object(Title), true, true, Object(Language))
#20 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(461): Message->parseText('__NOEDITSECTION...')
#21 /usr/local/apache/common-local/php-1.21wmf2/includes/Message.php(523): Message->toString()
#22 /usr/local/apache/common-local/php-1.21wmf2/includes/OutputPage.php(3544): Message->parseAsBlock()
#23 /usr/local/apache/common-local/php-1.21wmf2/includes/OutputPage.php(3532): OutputPage->addWikiMsgArray('deletedtext', Array)
#24 /usr/local/apache/common-local/php-1.21wmf2/includes/Article.php(1629): OutputPage->addWikiMsg('deletedtext', 'Talk:domino', '[[Special:Log/d...')
#25 /usr/local/apache/common-local/php-1.21wmf2/includes/Article.php(1457): Article->doDelete('so it is; I'll ...', false)
#26 /usr/local/apache/common-local/php-1.21wmf2/includes/actions/DeleteAction.php(38): Article->delete()
#27 /usr/local/apache/common-local/php-1.21wmf2/includes/Wiki.php(428): DeleteAction->show()
#28 /usr/local/apache/common-local/php-1.21wmf2/includes/Wiki.php(305): MediaWiki->performAction(Object(Article))
#29 /usr/local/apache/common-local/php-1.21wmf2/includes/Wiki.php(554): MediaWiki->performRequest()
#30 /usr/local/apache/common-local/php-1.21wmf2/includes/Wiki.php(447): MediaWiki->main()
#31 /usr/local/apache/common-local/php-1.21wmf2/index.php(59): MediaWiki->run()
#32 /usr/local/apache/common-local/live-1.5/index.php(3): require('/usr/local/apac...')
#33 {main}

[18-Oct-2012 07:11:07] Fatal error: Call to a member function getText() on a non-object at /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php on line 605
Server: mw24
Method: GET
URL: http://en.wiktionary.org/w/index.php?title=binder&action=rollback&from=66.108.89.183&token=c243388f3607a82694e0d40770a7403b%2B%5C
Backtrace:
#0 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(605): Message::parseText()
#1 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(428): Message->parseText('[[Special:Tags|...')
#2 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(466): Message->toString()
#3 /usr/local/apache/common-local/php-1.21wmf1/includes/ChangeTags.php(72): Message->parse()
#4 /usr/local/apache/common-local/php-1.21wmf1/includes/ChangeTags.php(52): ChangeTags::tagDescription('no-L3')
#5 /usr/local/apache/common-local/php-1.21wmf1/includes/ChangesList.php(537): ChangeTags::formatSummaryRow('no-L3', 'changeslist')
#6 /usr/local/apache/common-local/php-1.21wmf1/includes/ChangesList.php(646): ChangesList->insertTags('(diff | <a href...', Object(RecentChange), Array)
#7 /usr/local/apache/common-local/php-1.21wmf1/includes/specials/SpecialRecentchanges.php(528): OldChangesList->recentChangesLine(Object(RecentChange), false, 5)
#8 /usr/local/apache/common-local/php-1.21wmf1/includes/specials/SpecialRecentchanges.php(179): SpecialRecentChanges->webOutput(Object(ResultWrapper), Object(FormOptions))
#9 /usr/local/apache/common-local/php-1.21wmf1/includes/SpecialPage.php(611): SpecialRecentChanges->execute('limit=5,hidepat...')
#10 /usr/local/apache/common-local/php-1.21wmf1/includes/SpecialPageFactory.php(497): SpecialPage->run('limit=5,hidepat...')
#11 /usr/local/apache/common-local/php-1.21wmf1/includes/SpecialPageFactory.php(536): SpecialPageFactory::executePath(Object(Title), Object(RequestContext), true)
#12 /usr/local/apache/common-local/php-1.21wmf1/includes/parser/Parser.php(3343): SpecialPageFactory::capturePath(Object(Title), Object(RequestContext))
#13 /usr/local/apache/common-local/php-1.21wmf1/includes/parser/Preprocessor_DOM.php(1083): Parser->braceSubstitution(Array, Object(PPFrame_DOM))
#14 /usr/local/apache/common-local/php-1.21wmf1/includes/parser/Parser.php(3043): PPFrame_DOM->expand(Object(PPNode_DOM), 0)
#15 /usr/local/apache/common-local/php-1.21wmf1/includes/parser/Parser.php(1141): Parser->replaceVariables('Reverted edits ...')
#16 /usr/local/apache/common-local/php-1.21wmf1/includes/parser/Parser.php(370): Parser->internalParse('Reverted edits ...')
#17 /usr/local/apache/common-local/php-1.21wmf1/includes/cache/MessageCache.php(873): Parser->parse('Reverted edits ...', Object(Title), Object(ParserOptions), true)
#18 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(605): MessageCache->parse('Reverted edits ...', Object(Title), true, true, Object(Language))
#19 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(434): Message->parseText('Reverted edits ...')
#20 /usr/local/apache/common-local/php-1.21wmf1/includes/Message.php(496): Message->toString()
#21 /usr/local/apache/common-local/php-1.21wmf1/includes/actions/RollbackAction.php(108): Message->parseAsBlock()
#22 /usr/local/apache/common-local/php-1.21wmf1/includes/Action.php(541): RollbackAction->onView()
#23 /usr/local/apache/common-local/php-1.21wmf1/includes/Wiki.php(427): FormlessAction->show()
#24 /usr/local/apache/common-local/php-1.21wmf1/includes/Wiki.php(304): MediaWiki->performAction(Object(Article))
#25 /usr/local/apache/common-local/php-1.21wmf1/includes/Wiki.php(553): MediaWiki->performRequest()
#26 /usr/local/apache/common-local/php-1.21wmf1/includes/Wiki.php(446): MediaWiki->main()
#27 /usr/local/apache/common-local/php-1.21wmf1/index.php(59): MediaWiki->run()
#28 /usr/local/apache/common-local/live-1.5/index.php(3): require('/usr/local/apac...')
#29 {main}


Version: unspecified
Severity: normal

Details

Reference
bz41186

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:00 AM
bzimport set Reference to bz41186.
bzimport added a subscriber: Unknown Object (MLST).
Reedy created this task.Oct 18 2012, 6:58 PM

Is this reproducible? Only for the specific URLs, or in general?

The local customisation at http://en.wiktionary.org/w/index.php?title=MediaWiki:deletedtext&action=edit causes SpecialRecentChanges to get executed. In messagecache there is guard for calling parser inside parser, which returns string as opposed to parseroutput returned by $parser->parse().

Maybe Tim could help to explain how to call parser recursively (or use different parser?).

Changing ->parse() to ->text() in Lqt could avoid one of the cases but there are lots more.

  • Bug 41642 has been marked as a duplicate of this bug. ***

Not entirely sure how to reproduce this.

demon set Security to None.
Bawolff added a subscriber: Bawolff.Jun 1 2015, 1:40 PM

The local customisation at http://en.wiktionary.org/w/index.php?title=MediaWiki:deletedtext&action=edit causes SpecialRecentChanges to get executed. In messagecache there is guard for calling parser inside parser, which returns string as opposed to parseroutput returned by $parser->parse().

Maybe Tim could help to explain how to call parser recursively (or use different parser?).

See the getFreshParser() method of the parser.

hashar renamed this task from Call to a member function getText() on a non-object at Message.php to LQT: Call to a member function getText() on a non-object at Message.php.Jun 3 2015, 1:01 PM
hashar lowered the priority of this task from Medium to Low.Jun 11 2015, 4:14 PM
Jdforrester-WMF lowered the priority of this task from Low to Lowest.Aug 4 2016, 11:34 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

LiquidThreads has been replaced by StructuredDiscussions on all Wikimedia production wikis (except one, which will be done soon). It is no longer under active development or maintenance, so I'm re-classifying all open LQT tasks as "Lowest" priority.

Nemo_bis raised the priority of this task from Lowest to Medium.Aug 24 2016, 7:26 PM
Krinkle closed this task as Declined.Oct 27 2018, 8:59 PM
Krinkle added a subscriber: Krinkle.

Not seen in WMF Logstash for at least 30 days.

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:12 PM