Page MenuHomePhabricator

[Regression] Error creating thumbnail: Error reading SVG:Invalid URI
Closed, DeclinedPublic

Description

This seems a recent regression because some of these files had cached thumbs which were not able to be regenerated after purge.
[[File:Aarde Neptunus.svg]]
[[File:ABS-6321.0.55.001-IndustrialDisputesAustralia-IndustrialDisputesWhichOccurredDuringPeriod-WorkingDaysLost-Quarter-DisputeOccurred-A2540828A.svg]]
[[File:ABS-5302.0-BalancePaymentsInternationalInvestmentPositionAustralia-InternationalInvestment-ForeignAssetsByDirectionTypeInvestment FinancialYear-ChangesInPositionReflecting Transactions-DirectInvestmentAdjustment-A3535451L.svg]]
[[File:ABS-5206.0-AustralianNationalAccounts-NationalIncomeExpenditureProduct-ExpenditureOnGrossDomesticProductChainVolumeMeasures-Private-GrossFixedCapitalFormation TotalPrivateBusinessInvestment-A2302498T.svg]]
[[File:ABS-8755.0-ConstructionWorkDoneAustraliaPreliminary-ValueBuildingWorkDoneChainVolumeMeasuresStatesTerritoriesSeasonallyAdjusted-ValueWorkDoneDuringQuarter-ChainVolumeMeasures-TotalSectorOwnership-TotalTypeWork-AustralianCapita-A404977V.svg]]
[[File:ABS-8755.0-ConstructionWorkDoneAustraliaPreliminary-ValueBuildingWorkDoneBySectorCurrentPricesAustralia-ValueWorkDoneDuringQuarter-PrivateSector-TotalTypeBuilder-TotalResidentialBuilding-TotalAlterations.AdditionsInclRefurbCon-A402085A.svg]]
[[File:County Road 2A.svg]]
[[File:SubespacioSuma.svg]]


Version: unspecified
Severity: normal

Details

Reference
bz41372

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:14 AM
bzimport set Reference to bz41372.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Oct 25 2012, 8:40 AM

Wow, talk about long file names.

These files seem to have 404 when trying to download the original. That's very scary sounding...

(In reply to comment #1)

These files seem to have 404 when trying to download the original.

So this bug is depending on bug #39615

(In reply to comment #0)

[[File:Aarde Neptunus.svg]]
[[File:ABS-6321.0.55.001-IndustrialDisputesAustralia-
IndustrialDisputesWhichOccurredDuringPeriod-WorkingDaysLost-Quarter-
DisputeOccurred-A2540828A.svg]]
[[File:ABS-8755.0-ConstructionWorkDoneAustraliaPreliminary-
ValueBuildingWorkDoneChainVolumeMeasuresStatesTerritoriesSeasonallyAdjusted-
ValueWorkDoneDuringQuarter-ChainVolumeMeasures-TotalSectorOwnership-
TotalTypeWork-AustralianCapita-A404977V.svg]]
[[File:ABS-8755.0-ConstructionWorkDoneAustraliaPreliminary-
ValueBuildingWorkDoneBySectorCurrentPricesAustralia-
ValueWorkDoneDuringQuarter-PrivateSector-TotalTypeBuilder-
TotalResidentialBuilding-TotalAlterations.AdditionsInclRefurbCon-A402085A.
svg]]
[[File:SubespacioSuma.svg]]

Works fine.

[[File:ABS-5302.0-BalancePaymentsInternationalInvestmentPositionAustralia-
InternationalInvestment-ForeignAssetsByDirectionTypeInvestment
FinancialYear-ChangesInPositionReflecting
Transactions-DirectInvestmentAdjustment-A3535451L.svg]]
[[File:ABS-5206.0-AustralianNationalAccounts-
NationalIncomeExpenditureProduct-
ExpenditureOnGrossDomesticProductChainVolumeMeasures-Private-
GrossFixedCapitalFormation
TotalPrivateBusinessInvestment-A2302498T.svg]]

No file by this name exists, but you can upload it.

[[File:County Road 2A.svg]]

Original file missing: "The resource could not be found."

(In reply to comment #3)

[[File:County Road 2A.svg]]

Original file missing: "The resource could not be found."

This file is already covered by bug #39615.
...As the other files work fine or seem to have never existed, I would propose: "Resolved Wontfix"

(In reply to comment #4)

(In reply to comment #3)

[[File:County Road 2A.svg]]

Original file missing: "The resource could not be found."

This file is already covered by bug #39615.
...As the other files work fine or seem to have never existed, I would
propose:
"Resolved Wontfix"

I think you mean either WORKSFORME or invalid. WONTFIX means real issue which we are intentionally not fixing

Possibly.
But we can not accurately say if ...A3535451L.svg and ...A2302498T.svg ever existed or not. Maybe they did and we will never find out. Therefore we will be unable to fix this bug. ;-)

Both look fine to me now. Are they still missing for you?

If we wanted to know if they ever existed we could look at [[commond:special:log/upload]]

Bugzilla being crappy :-p

Closing as worksforme as I think everything is resolved here. Reopen if I am wrong

(Still not sure what broke the file names in comment #0 )

(They're just wrapped because of a space in the middle; copy and pasting them in your search or location bar works.)(In reply to comment #8)