Page MenuHomePhabricator

[Story] Ability to filter recent changes and watchlist on Wikidata
Open, LowPublic

Description

I have the need to filter recent changes by various criteria, which is now possible. For example, I would like to filter out edits of titles and descriptions in languages I don't know at all, since I can't really help there. Similarly, sometimes I would like to overview only removal of links to srwiki, since I know the language and the wiki well and could easily help with that.

This could be done by improving Special:Recentchanges or by creating a new special page. Also might be done to the watchlist and Special:Log.

See Also:
T50496: Allow multiple user languages in preferences

Details

Reference
bz41686

Event Timeline

bzimport raised the priority of this task from to Low.
bzimport set Reference to bz41686.
bzimport added a subscriber: Unknown Object (MLST).
He7d3r added a comment.Nov 6 2012, 2:21 PM

There is a workaround using [[commons:MediaWiki:Gadget-rightsfilter.js]]:
https://www.wikidata.org/wiki/Wikidata:Contact_the_development_team?diff=342510

*** Bug 42289 has been marked as a duplicate of this bug. ***

Denny added a comment.Dec 6 2012, 1:01 PM

closing as duplicate.

Qgil added a comment.Dec 9 2012, 6:33 AM

(In reply to comment #3)

closing as duplicate.

Duplicate of what? fwiw Bug 42289 is still open.

Also this bug has been resolved as fixed, not duplicate.

Please clarify. Thank you!

Reopening as per comment 4. Denny: Please clarify. TIA!

A simple but IMHO useful default would be to show any property change addition or removal (e.g. add "instance of", remove "country of citizenship", etc.), and changes to the label and description in the user's language.

This would be even better with multiple languages (bug 48496).

I don't see an easy way to do this kind of filtering with the database structure we currently have, especially not with paging. It's possible, but not easy, unless i'm missing something.

Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
matej_suchanek set Security to None.

I don't see an easy way to do this kind of filtering with the database structure we currently have, especially not with paging. It's possible, but not easy, unless i'm missing something.

I also dont think it is easy.
Perhaps a recentchanges_props table? >.>

Addshore renamed this task from Ability to filter recent changes and watchlist on Wikidata to [Story] Ability to filter recent changes and watchlist on Wikidata.Dec 4 2015, 1:00 PM

I think that's related: a user requires a way to see changes related to its wiki language on Wikidata, not other languages. For example, on French Wikipedia, only have changes related to French.

Qgil removed a subscriber: Qgil.May 31 2016, 8:50 PM