User Preferences do not allow me to go to any other tab in IE9 due to "compatibility mode"
Closed, ResolvedPublic

Description

I just checked my User Prefs page, and it will not allow me to go to any of the other tabs. No matter which tab I click on, I stay on the User Profile tab page. The first three tabs just take me a little way down the User Profile tab page, and the other tabs take me down to the bottom of the User Profile tab page.


Version: unspecified
Severity: major
OS: Windows 7
Platform: PC
URL: http://en.wikipedia.org/wiki/Special:Preferences

Paine_Ellsworth created this task.Via LegacyNov 5 2012, 7:33 PM
Reedy added a comment.Via ConduitNov 6 2012, 1:21 AM

What version of IE are you using?

Aklapper added a comment.Via ConduitNov 6 2012, 10:37 AM

[Changing bug summary to actually describe the bug.]

Paine_Ellsworth added a comment.Via ConduitNov 7 2012, 10:16 PM

(In reply to comment #1)

What version of IE are you using?

v. 9.0.8112.16421

Also, my os is Win 7 Ult. I just checked again and the bug is still there. I have rebooted at least twice since I reported the bug, so it does not appear to be at my end. Thank you for your response!

Aklapper added a comment.Via ConduitNov 8 2012, 10:56 AM

Does this work correctly with another browser, in case you can test?

Paine_Ellsworth added a comment.Via ConduitNov 10 2012, 12:41 AM

(In reply to comment #4)

Does this work correctly with another browser, in case you can test?

Just downloaded Firefox 16. It does seem to be browser-specific. Something very squirrelly, because I just noted at the Village Pump that all the separating bullets are missing from Navbars (IE9). I checked those with Firefox, and the bullets appear in that browser. Sorry, as this does not appear to be anything you guys need to worry about. Thank you very much for your response and help!

Aklapper added a comment.Via ConduitNov 10 2012, 1:08 PM

No problem - I hope you'll find the reason why IE behaves so weirdly.

Paine_Ellsworth added a comment.Via ConduitNov 11 2012, 5:57 PM

(In reply to comment #6)

No problem - I hope you'll find the reason why IE behaves so weirdly.

I did. An editor who watches the VP (tech) responded that I had accidently engaged IE's "compatibility mode". Disengaging it brought both the bullets and my preference tabs back to life. At least you'll know what to tell the next bug reporter who hasn't read _Compatibility for Dummies_. lol!

Aklapper added a comment.Via ConduitNov 12 2012, 12:00 PM

Might be related to bug 41937 then...

Kipod added a comment.Via ConduitNov 16 2012, 7:44 PM

REPRODUCED on enwiki and on www.mediawiki.org . Reopening.

(In reply to comment #8)

Might be related to bug 41937 then...

no, it's not related. the patch that fixes bug 41937 is already deployed, and this problem still exists with IE7, and with IE-8/9 in compatibility mode.
(also, the other problem came from throwing an exception in IE, mainly because of an extra comma. this problem, unfortunately, does not throw any exception).

according to this:
https://en.wikipedia.org/w/index.php?title=Wikipedia%3AVillage_pump_%28technical%29&diff=503442043&oldid=503440558}

the problem exists *at least* since July of 2012.

this may actually point to a systemic issue: it seems that there is very little (if any) testing of new releases vs. IE, and probably none at all with IE in compatibility mode.

the fact that this is a crappy and non-standard-conformant browser is hardly an excuse. unfortunately, very large number of readers and editors use it, so this lackluster testing vs. IE is unacceptable.

peace.

Anomie added a comment.Via ConduitNov 20 2012, 4:50 PM

Gerrit changeset 34329 fixes IE8 compatibility mode. I don't have the ability to test IE7.

Paine_Ellsworth added a comment.Via ConduitNov 23 2012, 6:49 PM

(In reply to comment #10)

Gerrit change #34329 fixes IE8 compatibility mode. I don't have the ability
to test IE7.

May I ask, what about IE9?

Paine_Ellsworth added a comment.Via ConduitNov 23 2012, 6:53 PM

Also wanted to say that it does appear that someone is working on IE9's Compatibility View, because when I enable it, I can see the separators on Navbars that I couldn't see before. However the My preferences tabs still don't work.

Anomie added a comment.Via ConduitNov 24 2012, 12:15 AM

(In reply to comment #11)

(In reply to comment #10)
> Gerrit change #34329 fixes IE8 compatibility mode. I don't have the ability
> to test IE7.

May I ask, what about IE9?

I don't have the ability to test that either. But I would hope its compatibility mode is fixed by the same change.

Paine_Ellsworth added a comment.Via ConduitNov 24 2012, 9:36 AM

(In reply to comment #13)

(In reply to comment #11)
> (In reply to comment #10)
> > Gerrit change #34329 fixes IE8 compatibility mode. I don't have the ability
> > to test IE7.
>
> May I ask, what about IE9?

I don't have the ability to test that either. But I would hope its
compatibility mode is fixed by the same change.

Oddly, I have to enable Compatibility View in my IE9 browser to see that change. With CV disabled, all I get is an error box.

As I noted above, there is definite improvement. Now, when I'm in Compatibility View, the separator dots in Navbars are visible where they were not visible before that change. Also, back when the "automatically check the 'Minor edit' box on Edit pages" option was removed from "My preferences", I added code to my vector.js that did that same thing. So if I make an edit that's not "minor", I have to uncheck the box. When I started chasing this bug, the "Minor edit" box was automatically UNchecked. My vector.js code was still there, but the box was unchecked. Now, since the Gerrit change, the "Minor edit" box has been automatically checked again.

So the only bug that appears to remain (I haven't checked everything, so I don't know if there are other problems with the IE9 Compatibility View) that I'm aware of is the "My preferences" tab problem. When I enable CV, I cannot open any tab. If I click on another tab, I just go down to the bottom of the first-tab page. When I disable CV, only then can I access the other tabs.

I don't know if this is significant, but when I enable the CV, this bug page widens and a bottom slide bar appears. Then when I disable the CV, this page narrows to its proper width and the slide bar disappears.

Anomie added a comment.Via ConduitNov 25 2012, 1:41 AM

(In reply to comment #14)

So the only bug that appears to remain (I haven't checked everything, so I
don't know if there are other problems with the IE9 Compatibility View) that
I'm aware of is the "My preferences" tab problem. When I enable CV, I cannot
open any tab. If I click on another tab, I just go down to the bottom of the
first-tab page. When I disable CV, only then can I access the other tabs.

Just to be clear: are you testing this on a wiki running git master, or are you testing this against enwiki or another Wikimedia wiki?

Paine_Ellsworth added a comment.Via ConduitNov 25 2012, 2:17 AM

(In reply to comment #15)

Just to be clear: are you testing this on a wiki running git master, or are you
testing this against enwiki or another Wikimedia wiki?

I use IE9 in Win7 Ult directly. Also used is Firefox16, where it all works correctly, so I knew the problem was with IE9. The problems were noted on the English Wikipedia. This wasn't an extensive test, per se. I just saw some problems and opened this bug. That was a bit hasty, I know, however it appears to have led to what might be a "systemic" issue, as noted by Kipod in Comment 9. Do you think it will be possible to fix the My preferences tab issue with another Gerrit change?

Should also probably note that the VP (tech) link by Kipod in Comment 9 led me to a discussion with the editor who had the problems. Those problems also appear to be caused by IE9, however that editor has different problems:

Please see http://en.wikipedia.org/wiki/User_talk:Arjayay#VP_.28tech.29_entry

Anomie added a comment.Via ConduitNov 25 2012, 11:20 PM

(In reply to comment #16)

The problems were noted on the English Wikipedia.

The fix is not live on the English Wikipedia yet, so testing it there right now accomplishes nothing. Sometime later tomorrow (after 9pm UTC, IIRC), you should be able to test it on test.wikipedia.org, test2.wikipedia.org, or mediawiki.org (after clearing your cache).

Should also probably note that the VP (tech) link by Kipod in Comment 9 led me
to a discussion with the editor who had the problems. Those problems also
appear to be caused by IE9, however that editor has different problems:

If it's a different problem, it should be filed as a different bug.

Kipod added a comment.Via ConduitNov 26 2012, 8:18 PM

mediawiki.org is on 1.21wmf5, and i can confirm the problem is fixed there (using ie9).

Thanks!

peace.

matmarex added a comment.Via ConduitNov 27 2012, 6:10 AM

Marking as resolved fixed.

Paine_Ellsworth added a comment.Via ConduitDec 3 2012, 3:35 AM

Please, not so fast. The evidently elaborate type of testing performed apparently gave an incorrect result. I just checked my My preferences page, and it still won't leave the first tab when my IE9 is in Compatibility View. When I click on the 2nd tab, it just sends me down the page of the 1st tab. When I disable CV, the tabs work as they should.

As for filing a new bug for the different problem, that would be up to the editor who had the problem and knows the details. From what I can glean from our discussion, it is definitely a problem with his IE. Whether or not it is also evidence of a systemic issue is, in my opinion, up in the air.

Anomie added a comment.Via ConduitDec 3 2012, 4:34 AM

(In reply to comment #20)

Please, not so fast. The evidently elaborate type of testing performed
apparently gave an incorrect result. I just checked my My preferences page,
and it still won't leave the first tab when my IE9 is in Compatibility View.
When I click on the 2nd tab, it just sends me down the page of the 1st tab.
When I disable CV, the tabs work as they should.

Are you testing on enwiki (which is *not* updated with the fix yet, as it is scheduled to be deployed sometime tomorrow), or did you test on mediawiki.org?

Paine_Ellsworth added a comment.Via ConduitDec 3 2012, 7:42 AM

(In reply to comment #21)

Are you testing on enwiki (which is *not* updated with the fix yet, as it is
scheduled to be deployed sometime tomorrow), or did you test on mediawiki.org?

Yes, my test such as it is is on enwiki. No problemo, I'll check it again tomorrow. Then we'll see about closing this as "resolved fixed".

Aklapper added a comment.Via ConduitDec 3 2012, 9:20 AM

When a fix has been committed and merged into the code repository, a bug report is set to RESOLVED FIXED. You can set the status to VERIFIED once the fix has been *deployed* on servers such as Wikipedia which can take up to two weeks.

Anomie added a comment.Via ConduitDec 3 2012, 2:47 PM

(In reply to comment #23)

When a fix has been committed and merged into the code repository, a bug report
is set to RESOLVED FIXED. You can set the status to VERIFIED once the fix has
been *deployed* on servers such as Wikipedia which can take up to two weeks.

I just wanted to make sure Paine was still (incorrectly) testing against enwiki before reclosing. With IE you never know, it could have been a different problem in IE9 than it was in IE8 for some stupid reason.

(In reply to comment #22)

Yes, my test such as it is is on enwiki. No problemo, I'll check it again
tomorrow. Then we'll see about closing this as "resolved fixed".

FYI, the deploy is scheduled for 19:00–21:00 UTC. You can verify that the new version has been deployed by visiting [[Special:Version]]; if it says the MediaWiki version is "1.21wmf4" it hasn't been deployed, while if it says "1.21wmf5" it has. Once it has been deployed, be sure to clear your cache (see [[Wikipedia:Bypass your cache]]) if you still see issues.

Paine_Ellsworth added a comment.Via ConduitDec 4 2012, 4:35 AM

Thank you, Brad, and Andre, please forgive my ignorance of correct closure policy.

Paine_Ellsworth added a comment.Via ConduitDec 6 2012, 9:08 PM

FTR, The My Preferences tabs are now working correctly when Compatibility View in IE9 is enabled. Thank you, devs, thank you very much!

Paine_Ellsworth added a comment.Via ConduitDec 6 2012, 9:10 PM

PS. Bugzilla looks great, too!

Aklapper added a comment.Via ConduitDec 7 2012, 12:30 PM

Paine: Glad it works for you now :)

Paine_Ellsworth added a comment.Via ConduitDec 13 2012, 1:39 AM

Thank you, Andre! I don't know why I don't just scrap IE, but I've been with it since the beginning, well since the MS/Netscape wars. I started out with the early Netscape browsers, but the moment I loaded IE the Netscape developed all sorts of anomalies. If I dumped IE, the anomalies wouldn't stop. Even though IE had some problems as long as I kept the Netscape browser loaded, when I dumped Netscape, the IE problems went away. So I ended up sticking with IE. I guess MS had the better devs <g>. I have used Firefox a lot and Chrome a little, but neither measure up to IE, in my opinion. I'm rambling. Thank you again, so much for fixing this!

Paine_Ellsworth added a comment.Via ConduitDec 15 2012, 5:07 AM

According to the editor that also had similar (but not same) problems with his IE8, this bug fix corrected his problems as well. This was the editor who had posted to VP Tech, as mentioned in comment #9 above. Further verification.

Add Comment