Page MenuHomePhabricator

Make a multilingual wiki aware of localised names of its namespaces
Closed, DuplicatePublic

Description

For multilingual wikis, such as Wikimedia Commons or Wikidata, it would be nice if all language translations of a namespace name could be entered in the url and be resolved.

For example, http://wikidata.org/wiki/Benutzer:Aude as a URL should resolve as an alias for http://wikidata.org/wiki/User:Aude

It could be a global setting that a wiki could enable.

Perhaps all the language translations could be treated as aliases, in most simple way to do this.

More complex cases are where we have language specific subpages, like if I had http://wikidata.org/wiki/User:Aude/de then it might be nice for http://wikidata.org/wiki/Benutzer:Aude to resolve to there. This is beyond scope of this bug but just some extra consideration.


Version: unspecified
Severity: enhancement
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=10449
https://bugzilla.wikimedia.org/show_bug.cgi?id=41811

Details

Reference
bz41845

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 22 2014, 12:46 AM
bzimport set Reference to bz41845.
bzimport added a subscriber: Unknown Object (MLST).
aude created this task.Nov 7 2012, 11:54 AM

This has already been WONTFIX'ed at least two times and probably more, see bug 10342, bug 20798.

aude added a comment.Nov 7 2012, 2:29 PM

Not surprised this has been requested in previous bugs. I don't know if it's more feasible now and worth it for such use cases as Wikidata?

(In reply to comment #2)

Not surprised this has been requested in previous bugs. I don't know if it's
more feasible now and worth it for such use cases as Wikidata?

Wikidata is not the first multilingual wiki we have and at a first glance the previously mentioned reasons not to fix this are still there, but I suppose devs could as well change mind (adding to cc Aryeh, Chad and Roan who closed the previous bugs).

I doubt that. Nobody has suggested how to handle the conflicts.

  • This bug has been marked as a duplicate of bug 10342 ***
aude added a comment.Nov 9 2012, 3:18 PM

Maybe if we have http://gl.wikidata.org/wiki/Usuario:Aude and http://es.wikidata.org/wiki/Usuario:Aude

It's still the wiki but magically, based on the language code it sets the interface and content language correctly, and overriding $wgLanguageCode global?

This is not the normal use for the language code subdomains, which in the case of wikipedias are actual separate databases. In case of wikidata, it's still one single wiki with one database.

For item content, it's not a problem because items are in the main namespace on Wikidata. When we have stuff in the Property and Query namespace, it could be more of a concern, along with the standard mediawiki namespaces that would be nice to have more localised.

It makes sense that http://wikidata.org/wiki/Usuario:Aude would not work and this might not work for commons unless we had language codes in the url somewhere/somehow.

Yes, there are several wiki families out there which actually are a single multilingual wiki using language code based fake subdomains or subdirectories.
I've yet to see one that doesn't make your mind explode, though.

Not a duplicate, bug 10342 calls for the namespace aliases to be based on the user language (which can't really work). This calls for all aliases to work on a multilingual wiki. This seems doable:

I think bug 41807 might provide a clean way to solve this. If the content language was "mul", we could simply copy all aliases for all languages into the "mul" pseudo-language.

(In reply to comment #8)

Not a duplicate, bug 10342 calls for the namespace aliases to be based on the
user language (which can't really work). This calls for all aliases to work on
a multilingual wiki. This seems doable:
I think bug 41807 might provide a clean way to solve this. If the content
language was "mul", we could simply copy all aliases for all languages into the
"mul" pseudo-language.

You've not read comment 4, have you? The same name can be an alias for different namespaces in different languages.
This might not be a duplicate of bug 10342 and bug 20798, but the problems are the same.

You still haven't explained what we're going to do about Stampa: and Datoteka:.

Relevant wikitech-l thread:
http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/56767

Platonides' note is also notable:
http://thread.gmane.org/gmane.science.linguistics.wikipedia.technical/56767/focus=56784

(In reply to comment #9)

You've not read comment 4, have you? The same name can be an alias for
different namespaces in different languages.

Yes. But since the aliases for "mul" can be defined manually, like the aliases fro other languages, it would be no problem to find alternatives for these languages. If not all namespaces for all languages will be the same as on wikipedia, I can live with it. 90% would be a great help.

(In reply to comment #10)

You still haven't explained what we're going to do about Stampa: and Datoteka:

Just pick one and live with it. Making life easier for 90% of users is more important than an inconsistency in the long tail.

(In reply to comment #11)

(In reply to comment #10)

You still haven't explained what we're going to do about Stampa: and Datoteka:

Just pick one and live with it. Making life easier for 90% of users is more
important than an inconsistency in the long tail.

I recommend prioritizing the languages with the most speakers, in this case Albanian and Serbo-Croatian. So "Stampa" = NS_TEMPLATE and "Datoteka" = NS_FILE.

  • Bug 42028 has been marked as a duplicate of this bug. ***

Making the bug summary more general to clarify what's the actual bottleneck that prevents magic words, aliases and anything from mapping namespace in different languages.

(In reply to Niklas Laxström from comment #4)

I doubt that. Nobody has suggested how to handle the conflicts.

You still haven't explained what we're going to do about Stampa: and Datoteka:

Just pick one and live with it. Making life easier for 90% of users is more
important than an inconsistency in the long tail.

Sounds like a nightmare in the very likely case there is no universal agreement on what language should prevail (cf. comment 12) or, even worse, the prevailing language changes later (cf. http://www.w3.org/Provider/Style/URI.html ).

Nemo_bis closed this task as Declined.Jun 4 2015, 5:33 PM
Nemo_bis claimed this task.

All the supposedly blocked bugs have been closed, looks like there is no demand for this any longer?

daniel added a comment.Jun 4 2015, 6:27 PM

@He7d3r considering T12342 was declined in 2007, and did not discuss multilingual wikis as far as I can tell, perhaps it makes sense to discuss this again. IIf you think this is a dupe, the consequence would be to re-open the original ticket. What do you think?

Snaevar removed a subscriber: Snaevar.Jun 8 2015, 7:01 PM
MGChecker added a subscriber: MGChecker.