Page MenuHomePhabricator

1.21wmf3 causes loading problems with IE in compatibility mode: exception for mw.centralNotice.initialize()
Closed, ResolvedPublic

Description

problem observed on enwiki and hewiki. probably exists elsewhere.

REPRODUCTION:

  • in internet explorer 8 or 9, use Tools => Internet Options => Advance, and mark the checkbox "Display notification on every script error".
  • Activate "Compatilbility mode"
  • Open main page in hewiki or enwiki

WHAT WILL YOU SEE

  • you get an exception on call to mw.centralNotice.initialize() (mw.centralNotice is null at the time this code executes)
  • you will get consecutive exceptions that depend on which wiki is it
  • if you log in to your account, many of your preferences will not be respected. e.g., if you enabled the "navpop" (aka "popup") gadget on enwiki, it will fail to work.

peace.


Version: unspecified
Severity: normal

Details

Reference
bz41937

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 12:52 AM
bzimport set Reference to bz41937.
Kipod created this task.Nov 9 2012, 11:15 PM
Kipod added a comment.Nov 9 2012, 11:34 PM

(addition): tested some more wikis: es, nl, de, ar, fa, pt - first exception (centralNotice) is same on all those wikis.
continuation varies depending on wiki, but each of those had at least one exception.

tentative diagnosis: for all sane browsers, mediawiki.util is loaded before site-specific common.js.
for some perverted reason, not so for IE in compatibility mode.

(this pertains to the other exceptions - i have no idea where centralNotice is supposed to be initialized).

peace.

mwalker wrote:

Kipod: thanks for the report! Hopefully the above patch will fix things. A couple of things were happening that shouldn't have been.

I've removed the dependency on mw.util (it didn't need it). This in and of itself should solve the issue. If it doesn't I've also modified the CentralNotice skin hook to explicitly depend on the CN module. However, this skin change will take some time to propogate through the system (ie: it will only take effect on the page when the page is purged/edited.)

mwalker wrote:

*** Bug 41750 has been marked as a duplicate of this bug. ***

Patch has been merged => can this be closed as RESOLVED FIXED?

TheDJ added a comment.Nov 12 2012, 2:30 PM

@Andre, this really also needs to be deployed asap. I think we can close it then.