wikieditor-toolbar-help-content-signaturetimestamp-result: Parse error at position 19 in input:
Closed, ResolvedPublic

Description

Author: rogerchrisman

Description:
Error observed on en.Wikipedia.org on November 14, 2012, time of this posting.

Edit page has a dropdown Edit help feature above the edit field. I think this is a WikiEditor feature called the Magic Bar. In that click the "Edit" drop down item (between "Special characters" and "Cite", towards right end of bar). At left of dropdown frame is now a scrollable selection area. Scroll to bottom of that and click on the item labeled "Discussion" in there. The two examples of signatures there under "What you get" in right column contain, above the expected example, this error message:

wikieditor-toolbar-help-content-signaturetimestamp-result: Parse error at position 19 in input:

Hope this helps. Cheers, Roger


Version: unspecified
Severity: minor
URL: http://en.wikipedia.org/w/index.php?title=Muban&action=edit
See Also:

bzimport added projects: WikiEditor, JavaScript.Via ConduitNov 22 2014, 1:05 AM
bzimport added a subscriber: Unknown Object (MLST).
bzimport set Reference to bz42107.
bzimport created this task.Via LegacyNov 14 2012, 6:54 PM
Aklapper added a comment.Via ConduitNov 16 2012, 2:08 PM

Confirming.

Aklapper added a comment.Via ConduitNov 16 2012, 2:08 PM

Created attachment 11375
Screenshot

Attached:

Nullzero added a comment.Via ConduitFeb 15 2013, 4:37 AM

It also occurs at Thai Wikipedia.

Aklapper added a comment.Via ConduitApr 16 2013, 8:04 AM

Still valid.

  1. Be logged in
  2. Go to https://en.wikipedia.org/w/index.php?title=Be_Here_Now_%28album%29&action=edit
  3. Click v Help
  4. Scroll down to "Discussion"
  5. Click it

See under "What you get":

wikieditor-toolbar-help-content-signature-result: Parse error at position 19 in input: Username (talk)

and others.

He7d3r added a comment.EditedVia ConduitAug 31 2013, 3:03 PM

This is not Firefox specific (I can reproduce it on Google Chrome 29.0.1547.62).

I installed the extension in my copy of MW and added the code

if( p === 'wikieditor-toolbar-help-content-signaturetimestamp-result' ){
	console.log( mw.loader.getState( 'mediawiki.jqueryMsg' ) );
}

right before the line return mediaWiki.msg( p ); from the function $.wikiEditor.autoMsg[1]. After reloading the page a few times I noticed the following:

  • Every time mediawiki.jqueryMsg was "ready" the error occurred
  • Every time mediawiki.jqueryMsg was "loaded" there was no error

So, this bug (as well as T54479, and probably the one described on T53321 comment 12) only happens when the module "mediawiki.jqueryMsg" changes the behavior of the function "mediaWiki.msg" (also known as "mw.msg"). This shorthand is used by WikiEditor since 2010 (see r75491#115), but on
Change-Id: I0d220692262356a12e2f1c0ce30cf6f090428332
the format of the shorthand was modified from "plain" (which WikiEditor was using) to "text".

It is likely that using
return mediaWiki.message( p ).plain();
would solve this.

[1] https://git.wikimedia.org/blob/mediawiki%2Fextensions%2FWikiEditor.git/8981f855a8dfdb3134da18647bb023d1bff3ad7e/modules%2Fjquery.wikiEditor.js#L151

gerritbot added a comment.Via ConduitAug 31 2013, 3:07 PM

Change 82092 had a related patch set uploaded by Helder.wiki:
Use mediaWiki.message( ... ).plain()

https://gerrit.wikimedia.org/r/82092

gerritbot added a comment.Via ConduitSep 28 2013, 12:18 PM

Change 82092 merged by jenkins-bot:
Use mediaWiki.message( ... ).plain()

https://gerrit.wikimedia.org/r/82092

He7d3r edited the task description. (Show Details)Via WebDec 21 2015, 11:40 PM
He7d3r set Security to None.
TheDJ reopened this task as "Open".Via WebDec 24 2015, 1:20 PM
TheDJ added a subscriber: TheDJ.

https://gerrit.wikimedia.org/r/113307 probably dealt with this in a more sustainable way, and I think we should revert the above patch with https://gerrit.wikimedia.org/r/#/c/260513/ in order to avoid recurring problems like: T62695: {{SITENAME}} not parsed: "Publish to {{SITENAME}}" as message box title when $wgDefaultUserOptions['wikieditor-publish'] = 1

I notice that this messages

  • wikieditor-toolbar-help-content-signaturetimestamp-result
  • wikieditor-toolbar-help-content-signature-result

Still have non parseable #{{special:mypage}} inside the signature message. These messages should probably be mass replaced and parameterized, just as we have done with the namespaces and the thumb keyword at some point.

gerritbot added a subscriber: gerritbot.Via ConduitDec 24 2015, 11:55 PM

Change 260952 had a related patch set uploaded (by TheDJ):
Remove non-working #{{special:mypage}} from help

https://gerrit.wikimedia.org/r/260952

gerritbot added a project: Patch-For-Review.Via ConduitDec 24 2015, 11:55 PM
gerritbot added a comment.Via ConduitDec 28 2015, 4:32 AM

Change 260952 merged by jenkins-bot:
Remove non-working {{#special:mypage}} from help

https://gerrit.wikimedia.org/r/260952

TheDJ closed this task as "Resolved".Via WebDec 28 2015, 8:23 AM
TheDJ claimed this task.
Catrope removed a subscriber: Catrope.Via WebFri, Jan 15, 10:46 PM

Add Comment