Page MenuHomePhabricator

Mobile version of Wikipedia doesn't properly link history (required for attribution) when accessing article via redirect
Closed, ResolvedPublic

Description

When accessing a Wikipedia article via a redirect (for instance, https://m.en.wikipedia.org/wiki/Mitigating_factors):

  • The correct article is displayed, but:
  • The link in the footer ("contributors") used for attribution contains the URL entered, and therefore only links to the users who created the redirect (or worked on the page prior to its being turned into a redirect).

The "contributors" link is important for legal compliance with the attribution requirement of the CC BY-SA license. See also [[bug:3391200 and [[bug:34292]].


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=69656

Details

Reference
bz42660

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:14 AM
bzimport set Reference to bz42660.

typo above, I meant [[bug:33912]]

Another typo above, sorry -- the example URL should be https://m.en.wikipedia.org/wiki/Mitigating_factors (I reversed "m.en"). Also bumping importance to "critical" since this is a feature that puts many articles (tens of thousands? Hundreds?) out of compliance with the CC BY-SA license.

Setting back to major due to http://www.mediawiki.org/wiki/Bugzilla/Fields#Severity but increasing priority

Thanks Andre, I'm glad to have the info about the difference between severity and priority. Also thanks Matthew for…correcting my correction. Severe and critical dyslexia, apparently…

I noticed today that visiting the "contributors" link in the page footer of the Android app is broken. I'm guessing that is the same root cause as this bug?

Ah, looking at Matthew's link, it looks like it might be a different bug. I'll file a new report.

I'm moving this bug to the MediaWiki extensions/MobileFrontend.

Is there any reason why https://en.m.wikipedia.org/wiki/Mitigating_factors doesn't send a HTTP response code 301 to redirect you to https://en.m.wikipedia.org/wiki/Mitigating_factor ?

(In reply to comment #9)

Is there any reason why https://en.m.wikipedia.org/wiki/Mitigating_factors
doesn't send a HTTP response code 301 to redirect you to
https://en.m.wikipedia.org/wiki/Mitigating_factor ?

So that you could see "Redirected from Mitigating factors".

(In reply to comment #10)

So that you could see "Redirected from Mitigating factors".

And when we do use HTTP redirects (e.g. https://www.mediawiki.org/wiki/Manual:$wgDisableHardRedirects) for on-wiki redirects, it's 302, since on-wiki redirects are very much not permanent.

Firstly I dispute the 'high/major' importance of this bug since the history is still there. The last edit was a redirect and it seems logical at least to me how you find the full history. What would you expect to see in this situation? Maybe an editor wants to see who set up the redirect and when? If we link to the full edit history of the content of the article this useful information gets lost. On a page with a large edit history e.g. http://en.wikipedia.org/w/index.php?title=Barack_Obama&action=history you still have to click on "older 50" to view the entire contribution history.

The person who setup the redirect is a contributor and surely under cc by sa should be credited as well??

Luis could you clarify what exactly is required to adhere to licensing - I was under the impression it was just a link to a page which allows you to view all the contributors to some content.
Specifically:

  1. Would linking to the last diff with history links back and forth adhere to the license?
  2. Would a list of all users that contributed to the page be sufficient? (or would it need to also link to their edit)
  3. If http://en.wikipedia.org/w/index.php?title=Mitigating_factors&action=history

linked to http://en.wikipedia.org/w/index.php?title=Mitigating_factor&action=history would this be acceptable?

Off topic but relating to redirects:
It still seems extremely strange to me that you'd have near identical content on 2 different urls. I understand the importance of redirects as I've been confused by this in the past (even the 'redirected from X' link is sometimes hard to spot and has led to much confusing). I'd personally prefer it to just link to the article (See [[Mitigating factor]]) - it seems really strange that you'd generate exactly the same page with a one line difference. In this particular case a 302 would make sense as the difference between titles is so minimal.

(In reply to comment #12)

Firstly I dispute the 'high/major' importance of this bug since the history
is
still there. The last edit was a redirect and it seems logical at least to me
how you find the full history. What would you expect to see in this
situation?

I'd expect a link to the history of the article I'm viewing. I'm not viewing the redirect, I'm viewing what I was redirected to.

If I'm not mistaken, I have to do three clicks to see the right history:

  1. "Last modified 3 months ago", taking me to the wrong history page.
  2. Click link in "Redirected page to Mitigating factor". *Only* works if they used the default redirect message, or included their own link
  3. Click "Last modified 3 months ago" again.

Maybe an editor wants to see who set up the redirect and when? If we link to
the full edit history of the content of the article this useful information
gets lost.

That's the point of the "Redirected from" link, which seems to be hidden/absent on Mobile. If you're interested in the redirect itself, you follow that link.

The person who setup the redirect is a contributor and surely under cc by sa
should be credited as well??

And they are, if you follow the "Redirected from" link.

Off topic but relating to redirects:
It still seems extremely strange to me that you'd have near identical content
on 2 different urls. I understand the importance of redirects as I've been
confused by this in the past (even the 'redirected from X' link is sometimes
hard to spot and has led to much confusing).

You said yourself, "Maybe an editor wants to see who set up the redirect". The redirect link provides a way to get that kind of information, as well as a way to edit the redirect (add a template, change the target, etc.)

I'd personally prefer it to just
link to the article (See [[Mitigating factor]])

You're saying if I go to https://en.m.wikipedia.org/wiki/Mitigating_factors I should see a link to https://en.m.wikipedia.org/wiki/Mitigating_factor ? I think that's very inefficient. Most of the time people are going to want to see and/or edit the actual article (i.e target of the redirect). There shouldn't be an extra click for that case.

  • it seems really strange that you'd generate exactly the same page with a one line difference. In this particular case a 302 would make sense as the difference between titles is so minimal.

If it's a 302, how do you propose allowing people to change the redirect? I don't think there should be a special case for minimal differences like "factor/factors". That would probably add confusion.

Related URL: https://gerrit.wikimedia.org/r/68116 (Gerrit Change Ie02c45744b636ba1c1cf715b90329819d94f29aa)

That should do it. It needs to be tested on an environment with an actual m. domain, but it should work since it still calls updateMobileUrlHost. It does not preserve mobileaction any more, but it looks like mobile uses the desktop history page anyway.

Hey Matt thanks for the patch. I'll get that tested with the mobile domain.
Luis: I would still be keen to fully comprehend the legal requirements of the history link as we keep running into these issues and will continue to do so without a policy which explains what is acceptable and what is not.

A few replies on the off topic discussion about redirects. Note: this is all me thinking aloud. I suspect any change here would require a big overhaul in how things currently are that is probably not worthwhile but I think these reflective discussions are useful to understand the reasoning behind why things are the current way and if they are correct.

"I'd expect a link to the history of the article I'm viewing. I'm not viewing

the redirect, I'm viewing what I was redirected to."

This is fair I just wondered if there were any arguments for the alternative.

"If I'm not mistaken, I have to do three clicks to see the right history:"

Correct, but i was wondering if the history page for the redirect should link to the history page for the thing it redirects to.

"That's the point of the "Redirected from" link, which seems to be hidden/absent

on Mobile. If you're interested in the redirect itself, you follow that link.""

"> The person who setup the redirect is a contributor and surely under cc by sa

should be credited as well??
"And they are, if you follow the "Redirected from" link."

... but should this be part of the page history for the article it redirects to as well? What does the license actually require?

"You're saying if I go to https://en.m.wikipedia.org/wiki/Mitigating_factors I

should see a link to https://en.m.wikipedia.org/wiki/Mitigating_factor ? I
think that's very inefficient. Most of the time people are going to want to
see and/or edit the actual article (i.e target of the redirect). There
shouldn't be an extra click for that case."

No this is not what I'm saying. I'm saying that in cases of misspellings or slight variations in title I think a 302 is acceptable.

In cases like:
https://en.wikipedia.org/wiki/Yo_mama_jokes
which shows the content of https://en.wikipedia.org/wiki/Maternal_insult
the titles are so different it is extremely confusing that a redirect occurred at all due to the existing UI to the point it could be seen as being broken (a few times I have run into this from search and wondering what the hell is going on). In these cases I'm questioning whether there should be a link saying See [[Maternal insult]]. The fact the user clicks on the link means they are aware of what is going on. In the current situation they are not.

"If it's a 302, how do you propose allowing people to change the redirect? I

don't think there should be a special case for minimal differences like
"factor/factors". That would probably add confusion."

This is an implementation detail and I'm sure is solvable if we were to go down this rabbit hole.

(In reply to comment #16)

... but should this be part of the page history for the article it redirects
to as well? What does the license actually require?

I don't think there has to be a direct link from Redirect Destination's history to Redirect Source's history (it's certainly never been there, and I don't recall anyone even complaining about this). It's debatable whether the redirect itself is copyrightable, but at any rate, I think two clicks (Destination (redirected from) Source (history) Source's history) is fine.

Thanks for the fix, guys. I agree with Matt's analysis in comment 17, except that I'm pretty comfortable saying that the redirect itself is not copyrightable, period. :)

Jon: "Luis: I would still be keen to fully comprehend the legal requirements of the history link as we keep running into these issues and will continue to do so
without a policy which explains what is acceptable and what is not."

Unfortunately, the answer is "it is complicated, and also, it depends". I'm working with Creative Commons on some things right now, and have put "write an attribution guide" on my TODO list, but it'll still be case-by-case for the reasonably near future, I'm afraid. :/

Thanks for replying Luis. It would be AWESOME to have an attribution guide.

At the moment however I'm mostly keen to understand if linking to the last diff (which has links to previous and next edits) is acceptable attribution...

Sorry, I missed that request - I've been swamped and admit I tuned out some of the details after I saw RESOLVED FIXED.

The full history page would be ideal (just to give fullest credit to our editors), but under our terms of use (which somewhat modify the terms of CC) the last diff would be acceptable.