VisualEditor: Sometimes the HotCat gadget appears at the top of the CE surface
Closed, DeclinedPublic

Description

From user report (but I've had this myself):

HotCat is a popular gadget and any conflict with it should be avoided. For
example, use VisualEditor on [[User:This, that and the other/sandbox/Schfoof]]
with HotCat enabled. The HotCat bar appears in the wrong place. (It probably
shouldn't appear at all.)
The conflict now appears to be fixed... very strange.

Given that it appears and also doesn't appear between refreshes - i.e., on the same page with the same version of the VE and HC code bases in the same accounts in the same browsers - I'm assuming it's some sort of race-condition, but I'm not sure.


Version: unspecified
Severity: minor

bzimport added a project: VisualEditor-MediaWiki.Via ConduitNov 22 2014, 1:01 AM
bzimport set Reference to bz43335.
Jdforrester-WMF created this task.Via LegacyDec 21 2012, 10:39 PM
bzimport added a comment.Via ConduitJul 4 2013, 2:05 PM

pearley wrote:

Is this related?

"We seem to have lost the plus and minus options of Hotcat that were one of the closest to WYSIWYG features of this site. Please can they be incorporated into visual editor. ϢereSpielChequers 13:46, 4 July 2013 (UTC)"

Jdforrester-WMF added a comment.Via ConduitJul 4 2013, 2:26 PM

(In reply to comment #1)

Is this related?

"We seem to have lost the plus and minus options of Hotcat that were one of
the closest to WYSIWYG features of this site. Please can they be
incorporated into visual editor. ϢereSpielChequers 13:46, 4 July 2013 (UTC)"

That's unrelated to VisualEditor; enwiki's community switched off HotCat as a default gadget, so people who want to keep using it will need to manually switch it back on.

Jdforrester-WMF added a comment.Via ConduitOct 15 2013, 10:54 PM
  • Bug 55759 has been marked as a duplicate of this bug. ***
Cmcmahon added a comment.Via ConduitOct 16 2013, 5:51 PM

Created attachment 13512
VE iframe has gadget code before VE is invoked

attachment invisible_iframe_contents.png ignored as obsolete

Catrope added a comment.Via ConduitNov 6 2013, 12:21 AM

(In reply to comment #4)

Created attachment 13512 [details]
VE iframe has gadget code before VE is invoked

I don't think that's related at all. Gadget CSS is expected in the iframe. It should be in the <head> instead of the <body> but that's a separate issue (bug 56630).

attachment invisible_iframe_contents.png ignored as obsolete

Krinkle added a comment.Via ConduitFeb 26 2014, 10:42 AM

Created attachment 14685
HotCat showing up in the content editable surface

(from bug 55759 attachment 13500 by Chris McMahon)

Attached:

Krenair added a comment.Via ConduitOct 22 2014, 8:25 PM

I can't reproduce this issue... If anyone still sees this, please reopen.

zeljkofilipin removed a subscriber: zeljkofilipin.Via WebDec 3 2014, 8:47 AM

Add Comment