Page MenuHomePhabricator

Summary field with 4 tildes should have its own separate message
Closed, ResolvedPublic

Description

An Lqt summary to which 4 tildes are added gets a message "It is not necessary to sign your post with four tildes. The signature is shown automatically."

This message is incorrect. Summaries do not get automatic signatures, as they are added as part of the start post of a thread.

Steps to reproduce:

  1. Go to URL (make sure you are logged in)
  2. Type "~~~~"

Observe that the warning is displayed in red above the edit area. Leave the page without making changes.

  1. Go to [1]. This is a full thread view of the thread that was summarised in URL.

Observe that the summary is part of the initial post in the thread and that no signature was added automatically for the summary.

[1] https://translatewiki.net/wiki/Thread:Support/About_MediaWiki:Cite_text/en


Version: master
Severity: trivial
URL: https://translatewiki.net/w/i.php?title=Thread:Support/About_MediaWiki:Cite_text/en&lqt_method=summarize&uselang=en

Details

Reference
bz43496

Event Timeline

bzimport raised the priority of this task from to Lowest.
bzimport set Reference to bz43496.
bzimport added a subscriber: Unknown Object (MLST).

Admittedly, though, summaries are usually not to be signed either, as they're supposed to be community-agreed summaries not owned by anyone in particular.
I've no idea if the error could be rephrased or should just be split for this other case.

(In reply to comment #1)

Admittedly, though, summaries are usually not to be signed either, as they're
supposed to be community-agreed summaries not owned by anyone in particular.
I've no idea if the error could be rephrased or should just be split for this
other case.

You mean there is at least one use case known where community agreed summaries are used that are not being signed? :)

(In reply to comment #2)

You mean there is at least one use case known where community agreed
summaries
are used that are not being signed? :)

No, I mean that it seems to be an assumption in the code, which for instance doesn't warn you about multiple users editing a summary, as it does for messages.

Qgil added a comment.Mar 19 2013, 5:33 PM

The default LQT functionality here makes sense. You are using summaries in a very specific way that doesn't belong to usual "threads".

As a simple solution you could edit the summary to say

"The following issue is closed by siebrand (chase)."

and then add a reply to the thread saying

"Already done when I checked."

that would appear automatically signed to you.

I agree with the current design and I would vote for a WONTFIX in this report.

Qgil added a comment.Apr 17 2014, 4:52 AM

One year of silence. Resolving as WONTFIX.

We forgot to clarify the nature of this report. It's not an enhancement request, it's a legitimate bug: [[mw:Localisation#Avoid_message_reuse]].
We just have to split the message in question, so that in the case of summaries it says the same thing with the correct words: "It is not necessary to sign your summary with four tildes".

Change 182757 had a related patch set uploaded (by Phoenix303):
Separate message for Summary field with 4 tildes

https://gerrit.wikimedia.org/r/182757

Patch-For-Review

Change 182758 had a related patch set uploaded (by Phoenix303):
Separate message for Summary field with 4 tildes

https://gerrit.wikimedia.org/r/182758

Patch-For-Review

Change 182761 had a related patch set uploaded (by Phoenix303):
Separate message for Summary field with 4 tildes

https://gerrit.wikimedia.org/r/182761

Patch-For-Review

Change 182758 abandoned by Phoenix303:
Separate message for Summary field with 4 tildes

https://gerrit.wikimedia.org/r/182758

Change 182761 abandoned by Phoenix303:
Separate message for Summary field with 4 tildes

Reason:
Duplicate

https://gerrit.wikimedia.org/r/182761

Nemo_bis set Security to None.

Change 182757 merged by jenkins-bot:
Separate message for Summary field with 4 tildes

https://gerrit.wikimedia.org/r/182757

Phoenix303 closed this task as Resolved.Aug 17 2015, 8:00 AM