Page MenuHomePhabricator

If a field name contains an ampersand, it then does not pick up the associated property.
Closed, ResolvedPublic

Description

Author: mitchell_neill

Description:
Hi.

I'm running SMW bundle 1.8, MW 1.19.3 and SF 2.5.1.

If a field name contains an ampersand, it then does not pick up the associated property.

For example:

! Parent & carers leisure info:

{{{fieldParent & carers leisure inforows=2cols=80}}}

does not pick up the text property in template:

! Parent and carers leisure info

[[Parent and Carers Leisure Info::{{{Children & young person leisure info|}}}]]

I have to manually specify the property in the form thus:

! Parent & carers leisure info:

{{{fieldParent & carers leisure infoproperty=Parent and Carers Leisure Inforows=2cols=80}}}

Version: master
Severity: normal

Details

Reference
bz43989

Event Timeline

bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz43989.

mitchell_neill wrote:

Same if field has a + symbol. For example:

! Person 18+:

{{{fieldPerson 18+}}}

This has been reported as fixed.

pawanseerwani+bugzilla wrote:

Hi,
I am running MW 1.23alpha ,SMW 1.9.1.1, SF 2.7.

The bug surely exists with '&' symbol

(In reply to Neill Mitchell from comment #1)

Same if field has a + symbol. For example:

It doesn't exist with '+' symbol.(Atleast in my case)

So the bug should be reopened.

  • Bug 62642 has been marked as a duplicate of this bug. ***

Change 120963 had a related patch set uploaded by Foxtrott:
fix bug 43989 (Ampersands not handled properly in SF tags)

https://gerrit.wikimedia.org/r/120963

Change 120963 merged by jenkins-bot:
fix bug 43989 (Ampersands not handled properly in SF tags)

https://gerrit.wikimedia.org/r/120963

All patches mentioned in this report are either merged or abandoned - is there more work left to do here (if yes: please reset the bug report status to NEW or ASSIGNED), or can you close this ticket as RESOLVED FIXED?

No reply to comment 8 - assuming this bug is FIXED.
If that is not the case: Please reopen and elaborate what is left to do here to get this report fixed.