Page MenuHomePhabricator

CAPTCHA module is activated by <references/> tag if a <ref> with an external link already exists
Closed, InvalidPublic

Description

See change http://ro.wikipedia.org/w/index.php?title=Dorgo%C8%99%2C_Arad&diff=7378806&oldid=6024350

Add a <references/> tag as an anon user. If the references contain external links, you are prompted for a captcha because "your change adds external links".

This is confusing and useless.


Version: master
Severity: minor
URL: http://ro.wikipedia.org/w/index.php?title=Dorgo%C8%99%2C_Arad&diff=7378806&oldid=6024350

Details

Reference
bz44505

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:23 AM
bzimport set Reference to bz44505.
bzimport added a subscriber: Unknown Object (MLST).
Strainu created this task.Jan 30 2013, 12:21 PM

That sounds okay, because due to the <references /> the url is now visible on the section.

Maybe it is better, when adding the <ref> will give that captcha, but without a references tag the added url is not visible for everyone, so that is not trigger that.

It is definitely better to show the captcha on adding the ref, since you want to nag the potential spammer, not the person that just happened to make it visible.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 6 2015, 5:30 PM
Florian closed this task as Invalid.Aug 6 2015, 5:30 PM
Florian claimed this task.

Confirmed, it's solved. Thanks Florian!