VisualEditor: IME input into an empty slug causes characters to overwrite one another
Closed, ResolvedPublic

Description

Author: visionary.incident

Description:
I cannot input japanese consecutive characters in the beginning of the line.

Firefox version is 18.0.2 .

For example

inputed
あああああ

outputed
ああ


Version: unspecified
Severity: normal

bzimport set Reference to bz45240.
bzimport created this task.Via LegacyFeb 21 2013, 7:02 PM
Inez added a comment.Via ConduitFeb 21 2013, 8:01 PM

I was able to confirm it (using Katakana) in Chrome on MacOS. Apparently it depends on the speed of typing (Selenium test for it is going to be interesting).

Nicolas_Raoul added a comment.Via ConduitMar 24 2013, 11:52 AM

Only works if the line has no text.
Confirmed on bullet-type lines too.

Jdforrester-WMF added a comment.Via ConduitMay 3 2013, 2:23 AM

Inez, is there an update on this bug?

dchan added a comment.Via ConduitAug 24 2013, 12:54 PM
  • Bug 53064 has been marked as a duplicate of this bug. ***
Jdforrester-WMF added a comment.Via ConduitOct 8 2013, 10:32 PM

Just as a note, we are refactoring the Surface code in ContentEditable to make this fixable, hence the delay.

Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 27 2014, 12:57 AM
Jdforrester-WMF lowered the priority of this task from "High" to "Normal".Via WebJan 9 2015, 10:55 PM
Esanders closed this task as "Resolved".Via WebFeb 12 2015, 2:08 PM
Esanders claimed this task.

I suspect this is no longer broken. Please re-test.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.