Page MenuHomePhabricator

Partial rename for specific user on collabwiki
Closed, DeclinedPublic

Description

A user (Bjones) on collabwiki was renamed on Feb 22. After the rename, the user was not able to login with either the new or old username.

Looking in the DB, although revision.rev_user_text was updated for the new username, the user.user_name column was not.

I can't reproduce, but opening a bug in case other instances pop up.

Details

Reference
bz45746

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:20 AM
bzimport set Reference to bz45746.
bzimport added a subscriber: Unknown Object (MLST).
csteipp created this task.Mar 5 2013, 7:45 PM
MarcoAurelio updated the task description. (Show Details)Jul 20 2016, 1:50 PM
MarcoAurelio removed a subscriber: wikibugs-l-list.
MarcoAurelio raised the priority of this task from Low to Needs Triage.Jul 8 2017, 10:25 AM
MarcoAurelio added a subscriber: Aklapper.
MarcoAurelio added subscribers: Reedy, demon, MarcoAurelio.

Maybe renameUserCleanup.php would fix it. @Reedy @demon What do you think?

Is this needed now? It is 4 years since this task was created.

I'd say yes. I don't think we should leave corrupted data/tables, even if it is a private wiki. Running that script will be a matter of minutes. If it was not done before it's because it sat on the wrong project for all those years.

demon removed a subscriber: demon.Jul 11 2017, 5:05 PM
Reedy changed the task status from Open to Stalled.Jul 31 2017, 11:54 PM

We need the old and the new username

@Jalexander Ops require the log entry of the rename to be able to fix this. If you have access to that wiki, could you provide it to us? Thanks!

Reedy added a comment.Aug 1 2017, 12:01 AM
reedy@tin:/srv/mediawiki-staging$ mwscript extensions/Renameuser/renameUserCleanup.php --wiki=collabwiki --olduser=Bjones --newuser="BJones (WMF)"
Rename User Cleanup starting...

Found possible log entry of the rename, please check: Bjones with comment Consistency on 20130222064759
Found 0 edits to be re-attributed from table revision for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table archive for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table logging for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table image for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table oldimage for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table filearchive for uid 95
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table revision for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table archive for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table logging for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table image for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table oldimage for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Found 0 edits to be re-attributed from table filearchive for uid 0
If you proceed, the uid field will be set to that of the new user name (i.e. 95) in these rows.
Proceed? [N/y]  y
Done!
Reedy closed this task as Declined.Aug 1 2017, 12:03 AM

Not WMF staff any more.

User row looks correct